summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-office/gnumeric/files/digest-gnumeric-0.64-r1 (renamed from app-office/gnumeric/files/digest-gnumeric-0.64)0
-rw-r--r--app-office/gnumeric/gnumeric-0.64-r1.ebuild51
-rw-r--r--gnome-apps/evolution/evolution-0.10.ebuild39
-rw-r--r--gnome-office/gnumeric/files/digest-gnumeric-0.64-r1 (renamed from gnome-office/gnumeric/files/digest-gnumeric-0.64)0
-rw-r--r--gnome-office/gnumeric/gnumeric-0.64-r1.ebuild51
-rw-r--r--net-mail/evolution/evolution-0.10.ebuild39
6 files changed, 180 insertions, 0 deletions
diff --git a/app-office/gnumeric/files/digest-gnumeric-0.64 b/app-office/gnumeric/files/digest-gnumeric-0.64-r1
index b478595faf00..b478595faf00 100644
--- a/app-office/gnumeric/files/digest-gnumeric-0.64
+++ b/app-office/gnumeric/files/digest-gnumeric-0.64-r1
diff --git a/app-office/gnumeric/gnumeric-0.64-r1.ebuild b/app-office/gnumeric/gnumeric-0.64-r1.ebuild
new file mode 100644
index 000000000000..af36f7fce3a9
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-0.64-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-0.64-r1.ebuild,v 1.1 2001/05/17 13:29:30 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="gnumeric"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnumeric/"${A}
+HOMEPAGE="http://www.gnome.org/gnome-office/gnumeric.shtml"
+
+DEPEND=">=sys-devel/perl-5
+ >=dev-lang/python-2.0
+ >=gnome-base/gal-0.3.0
+ >=gnome-libs/gb-0.0.17
+ >=gnome-libs/libole2-0.1.7
+ bonobo? ( >=gnome-base/bonobo-0.28
+ >=gnome-libs/libgda-0.2.0 ) "
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp configure configure.orig
+ sed -e 's:"%d,:"%d",:' configure.orig > configure
+}
+
+src_compile() {
+ cd ${S}
+ local myconf
+ if [ "`use bonobo`" ]
+ then
+ myconf="--with-bonobo"
+ fi
+ LDFLAGS="-L/opt/gnome/lib -lunicode" try ./configure --host=${CHOST} --prefix=/opt/gnome \
+ ${myconf} --with-gb
+ cd ${S}
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/opt/gnome PREFIX=${D}/usr install
+ dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO
+
+}
+
+
+
+
+
+
diff --git a/gnome-apps/evolution/evolution-0.10.ebuild b/gnome-apps/evolution/evolution-0.10.ebuild
new file mode 100644
index 000000000000..5f458a77ad0e
--- /dev/null
+++ b/gnome-apps/evolution/evolution-0.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-apps/evolution/evolution-0.10.ebuild,v 1.1 2001/05/17 13:30:15 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A GNOME groupware application, a Microsoft Outlook workalike"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${A}"
+HOMEPAGE="http://www.helixcode.com"
+
+DEPEND=">=gnome-base/gnome-core-1.2.4
+ >=gnome-base/libunicode-0.4-r1
+ >=gnome-base/gal-0.5
+ >=gnome-base/gtkhtml-0.8.3
+ ldap? ( >=net-nds/openldap-1.2 )"
+
+src_compile() {
+
+ local myconf
+# if [ "`use ldap`" ] ; then
+# myconf="--enable-ldap=yes"
+# else
+ myconf="--enable-ldap=no"
+# fi
+ try ./configure --prefix=/opt/gnome --host=${CHOST} $myconf
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+ try make DESTDIR=${D} install
+ dodoc AUTHORS COPYING ChangeLog HACKING MAINTAINERS
+ dodoc NEWS README
+}
+
+
diff --git a/gnome-office/gnumeric/files/digest-gnumeric-0.64 b/gnome-office/gnumeric/files/digest-gnumeric-0.64-r1
index b478595faf00..b478595faf00 100644
--- a/gnome-office/gnumeric/files/digest-gnumeric-0.64
+++ b/gnome-office/gnumeric/files/digest-gnumeric-0.64-r1
diff --git a/gnome-office/gnumeric/gnumeric-0.64-r1.ebuild b/gnome-office/gnumeric/gnumeric-0.64-r1.ebuild
new file mode 100644
index 000000000000..5b1215785c8f
--- /dev/null
+++ b/gnome-office/gnumeric/gnumeric-0.64-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-office/gnumeric/gnumeric-0.64-r1.ebuild,v 1.1 2001/05/17 13:29:30 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="gnumeric"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnumeric/"${A}
+HOMEPAGE="http://www.gnome.org/gnome-office/gnumeric.shtml"
+
+DEPEND=">=sys-devel/perl-5
+ >=dev-lang/python-2.0
+ >=gnome-base/gal-0.3.0
+ >=gnome-libs/gb-0.0.17
+ >=gnome-libs/libole2-0.1.7
+ bonobo? ( >=gnome-base/bonobo-0.28
+ >=gnome-libs/libgda-0.2.0 ) "
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp configure configure.orig
+ sed -e 's:"%d,:"%d",:' configure.orig > configure
+}
+
+src_compile() {
+ cd ${S}
+ local myconf
+ if [ "`use bonobo`" ]
+ then
+ myconf="--with-bonobo"
+ fi
+ LDFLAGS="-L/opt/gnome/lib -lunicode" try ./configure --host=${CHOST} --prefix=/opt/gnome \
+ ${myconf} --with-gb
+ cd ${S}
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/opt/gnome PREFIX=${D}/usr install
+ dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO
+
+}
+
+
+
+
+
+
diff --git a/net-mail/evolution/evolution-0.10.ebuild b/net-mail/evolution/evolution-0.10.ebuild
new file mode 100644
index 000000000000..90bf41a7b27b
--- /dev/null
+++ b/net-mail/evolution/evolution-0.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-0.10.ebuild,v 1.1 2001/05/17 13:30:15 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A GNOME groupware application, a Microsoft Outlook workalike"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${A}"
+HOMEPAGE="http://www.helixcode.com"
+
+DEPEND=">=gnome-base/gnome-core-1.2.4
+ >=gnome-base/libunicode-0.4-r1
+ >=gnome-base/gal-0.5
+ >=gnome-base/gtkhtml-0.8.3
+ ldap? ( >=net-nds/openldap-1.2 )"
+
+src_compile() {
+
+ local myconf
+# if [ "`use ldap`" ] ; then
+# myconf="--enable-ldap=yes"
+# else
+ myconf="--enable-ldap=no"
+# fi
+ try ./configure --prefix=/opt/gnome --host=${CHOST} $myconf
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+ try make DESTDIR=${D} install
+ dodoc AUTHORS COPYING ChangeLog HACKING MAINTAINERS
+ dodoc NEWS README
+}
+
+