summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pyzmq/ChangeLog6
-rw-r--r--dev-python/pyzmq/pyzmq-2.1.7.ebuild41
-rw-r--r--dev-python/pyzmq/pyzmq-2.1.9.ebuild41
-rw-r--r--dev-python/pyzmq/pyzmq-2.2.0.1.ebuild49
-rw-r--r--dev-python/pyzmq/pyzmq-2.2.0.ebuild43
5 files changed, 5 insertions, 175 deletions
diff --git a/dev-python/pyzmq/ChangeLog b/dev-python/pyzmq/ChangeLog
index f2955d2c4f69..0d6a2860e8d2 100644
--- a/dev-python/pyzmq/ChangeLog
+++ b/dev-python/pyzmq/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pyzmq
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/ChangeLog,v 1.26 2013/02/06 00:38:50 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/ChangeLog,v 1.27 2013/02/06 08:38:47 djc Exp $
+
+ 06 Feb 2013; Dirkjan Ochtman <djc@gentoo.org> -pyzmq-2.1.7.ebuild,
+ -pyzmq-2.1.9.ebuild, -pyzmq-2.2.0.1.ebuild, -pyzmq-2.2.0.ebuild:
+ Remove old versions.
*pyzmq-2.2.0.1-r1 (06 Feb 2013)
diff --git a/dev-python/pyzmq/pyzmq-2.1.7.ebuild b/dev-python/pyzmq/pyzmq-2.1.7.ebuild
deleted file mode 100644
index bf28f0377954..000000000000
--- a/dev-python/pyzmq/pyzmq-2.1.7.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/pyzmq-2.1.7.ebuild,v 1.5 2012/02/20 10:24:15 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 *-jython 2.7-pypy-*"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils eutils
-
-DESCRIPTION="PyZMQ is a lightweight and super-fast messaging library built on top of the ZeroMQ library"
-HOMEPAGE="http://www.zeromq.org/bindings:python http://pypi.python.org/pypi/pyzmq"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="examples"
-
-RDEPEND=">=net-libs/zeromq-2.1"
-DEPEND="${RDEPEND}"
-
-DOCS="README.rst"
-PYTHON_MODNAME="zmq"
-
-src_test() {
- testing() {
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" nosetests -sv $(ls -d build-${PYTHON_ABI}/lib.*)
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/dev-python/pyzmq/pyzmq-2.1.9.ebuild b/dev-python/pyzmq/pyzmq-2.1.9.ebuild
deleted file mode 100644
index 33cbb834849c..000000000000
--- a/dev-python/pyzmq/pyzmq-2.1.9.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/pyzmq-2.1.9.ebuild,v 1.2 2012/02/20 10:24:15 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 *-jython 2.7-pypy-*"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils eutils
-
-DESCRIPTION="PyZMQ is a lightweight and super-fast messaging library built on top of the ZeroMQ library"
-HOMEPAGE="http://www.zeromq.org/bindings:python http://pypi.python.org/pypi/pyzmq"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-
-RDEPEND=">=net-libs/zeromq-2.1.9"
-DEPEND="${RDEPEND}"
-
-DOCS="README.rst"
-PYTHON_MODNAME="zmq"
-
-src_test() {
- testing() {
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" nosetests -sv $(ls -d build-${PYTHON_ABI}/lib.*)
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/dev-python/pyzmq/pyzmq-2.2.0.1.ebuild b/dev-python/pyzmq/pyzmq-2.2.0.1.ebuild
deleted file mode 100644
index 03aca3a3a633..000000000000
--- a/dev-python/pyzmq/pyzmq-2.2.0.1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/pyzmq-2.2.0.1.ebuild,v 1.5 2013/02/05 00:47:42 heroxbd Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*:2.6"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 2.5 *-jython 2.7-pypy-*"
-DISTUTILS_SRC_TEST="nosetests"
-PYTHON_TESTS_RESTRICTED_ABIS="3*"
-
-inherit distutils eutils
-
-DESCRIPTION="PyZMQ is a lightweight and super-fast messaging library built on top of the ZeroMQ library"
-HOMEPAGE="http://www.zeromq.org/bindings:python http://pypi.python.org/pypi/pyzmq"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples test"
-
-RDEPEND=">=net-libs/zeromq-2.1.9"
-DEPEND="${RDEPEND}
- test? ( dev-python/gevent
- www-servers/tornado )"
-
-DOCS="README.rst"
-PYTHON_MODNAME="zmq"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-2.2.0.1-python3.patch"
- distutils_src_prepare
-}
-
-src_test() {
- testing() {
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" nosetests -sv $(ls -d build-${PYTHON_ABI}/lib.*)
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/dev-python/pyzmq/pyzmq-2.2.0.ebuild b/dev-python/pyzmq/pyzmq-2.2.0.ebuild
deleted file mode 100644
index 5f5c6ecc05cd..000000000000
--- a/dev-python/pyzmq/pyzmq-2.2.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/pyzmq-2.2.0.ebuild,v 1.3 2012/08/29 17:00:38 floppym Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*:2.6"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 2.5 *-jython 2.7-pypy-*"
-DISTUTILS_SRC_TEST="nosetests"
-PYTHON_TESTS_RESTRICTED_ABIS="3*"
-
-inherit distutils eutils
-
-DESCRIPTION="PyZMQ is a lightweight and super-fast messaging library built on top of the ZeroMQ library"
-HOMEPAGE="http://www.zeromq.org/bindings:python http://pypi.python.org/pypi/pyzmq"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples test"
-
-RDEPEND=">=net-libs/zeromq-2.1.9"
-DEPEND="${RDEPEND}
- test? ( www-servers/tornado )"
-
-DOCS="README.rst"
-PYTHON_MODNAME="zmq"
-
-src_test() {
- testing() {
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" nosetests -sv $(ls -d build-${PYTHON_ABI}/lib.*)
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}