summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-physics/pythia/ChangeLog9
-rw-r--r--sci-physics/pythia/pythia-6.4.22.ebuild (renamed from sci-physics/pythia/pythia-6.4.20.ebuild)6
-rw-r--r--sci-physics/pythia/pythia-8.1.30.ebuild78
3 files changed, 89 insertions, 4 deletions
diff --git a/sci-physics/pythia/ChangeLog b/sci-physics/pythia/ChangeLog
index 2dd6be4421ad..6aa5f17556bb 100644
--- a/sci-physics/pythia/ChangeLog
+++ b/sci-physics/pythia/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-physics/pythia
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/ChangeLog,v 1.15 2009/09/21 05:40:09 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/ChangeLog,v 1.16 2009/11/23 07:15:40 bicatali Exp $
+
+*pythia-8.1.30 (23 Nov 2009)
+*pythia-6.4.22 (23 Nov 2009)
+
+ 23 Nov 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ -pythia-6.4.20.ebuild, +pythia-6.4.22.ebuild, +pythia-8.1.30.ebuild:
+ Version bumps
21 Sep 2009; Sébastien Fabbro <bicatali@gentoo.org>
+pythia-6.4.19.ebuild:
diff --git a/sci-physics/pythia/pythia-6.4.20.ebuild b/sci-physics/pythia/pythia-6.4.22.ebuild
index 34a2e58e8246..988c28d9c078 100644
--- a/sci-physics/pythia/pythia-6.4.20.ebuild
+++ b/sci-physics/pythia/pythia-6.4.22.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/pythia-6.4.20.ebuild,v 1.1 2009/03/18 16:19:40 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/pythia-6.4.22.ebuild,v 1.1 2009/11/23 07:15:40 bicatali Exp $
EAPI=2
-inherit fortran versionator autotools
+inherit versionator autotools
MV=$(get_major_version)
MY_PN=${PN}${MV}
@@ -14,7 +14,7 @@ DESCRIPTION="Lund Monte Carlo high-energy physics event generator"
HOMEPAGE="http://projects.hepforge.org/pythia6/"
# pythia6 from root is needed for some files to interface pythia6 with root.
-# To produce a split version on mirror do:
+# To produce a split version on mirror do, replace the 6.4.19 by the current version
# svn export http://svn.hepforge.org/pythia6/tags/v_6_4_19/ pythia-6.4.19
# tar cjf pythia-6.4.19.tar.bz2
SRC_URI="mirror://gentoo/${P}.tar.bz2
diff --git a/sci-physics/pythia/pythia-8.1.30.ebuild b/sci-physics/pythia/pythia-8.1.30.ebuild
new file mode 100644
index 000000000000..ee5cd950960d
--- /dev/null
+++ b/sci-physics/pythia/pythia-8.1.30.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/pythia-8.1.30.ebuild,v 1.1 2009/11/23 07:15:40 bicatali Exp $
+
+EAPI=2
+
+inherit eutils versionator
+
+MV=$(get_major_version)
+MY_P=${PN}$(replace_all_version_separators "" ${PV})
+
+DESCRIPTION="Lund Monte Carlo high-energy physics event generator"
+HOMEPAGE="http://home.thep.lu.se/~torbjorn/Pythia.html"
+SRC_URI="http://home.thep.lu.se/~torbjorn/${PN}${MV}/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="8"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE="doc examples +hepmc"
+
+DEPEND="hepmc? ( sci-physics/hepmc )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ use hepmc && export HEPMCVERSION=2 HEPMCLOCATION=/usr
+ # homemade configure script creates a useless config.mk
+ rm -f config.mk
+ cat > config.mk <<-EOF
+ SHAREDLIBS = yes
+ LDFLAGSSHARED = -shared ${LDFLAGS}
+ LDFLAGLIBNAME = -Wl,-soname
+ SHAREDSUFFIX = so
+ EOF
+}
+
+src_test() {
+ cd "${S}"/examples
+ # use emake for parallel instead of long runmains
+ emake \
+ $(ls main0{1..9}*.cc main1{0..5}*.cc | sed -e 's/.cc//') \
+ || die "emake tests failed"
+ for i in main0{1..9}*.exe main1{0..5}*.exe; do
+ ./${i} > ${i}.out || die "test ${i} failed"
+ done
+ if use hepmc; then
+ emake main31 main32 || die "emake tests for hepmc failed"
+ ./main31.exe > main31.exe.out || die
+ ./main32.exe main32.cmnd hepmcout32.dat > main32.exe.out || die
+ fi
+ emake clean && rm -f main*out
+}
+
+src_install() {
+ dolib.so lib/*so || die "shared lib install failed"
+ dolib.a lib/archive/* || die "static lib install failed"
+
+ insinto /usr/include/${PN}
+ doins include/* || die "headers install failed"
+
+ # xmldoc needed by root
+ insinto /usr/share/${PN}
+ doins -r xmldoc || die "xmldoc install failed"
+ echo PYTHIA8DATA=/usr/share/${PN}/xmldoc >> 99pythia8
+ doenvd 99pythia8
+
+ insinto /usr/share/doc/${PF}
+ dodoc GUIDELINES AUTHORS README
+ if use doc; then
+ doins worksheet.pdf || die "doc install failed"
+ mv htmldoc html
+ doins -r html || die "html doc install failed"
+ fi
+ if use examples; then
+ doins -r examples || die "examples install failed"
+ fi
+}