summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pip/ChangeLog7
-rw-r--r--dev-python/pip/pip-1.1.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-python/pip/ChangeLog b/dev-python/pip/ChangeLog
index c2f3d61cc30b..30136f2a541b 100644
--- a/dev-python/pip/ChangeLog
+++ b/dev-python/pip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pip
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.5 2012/02/16 13:27:49 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.6 2012/02/17 06:52:03 radhermit Exp $
+
+*pip-1.1 (17 Feb 2012)
+
+ 17 Feb 2012; Tim Harder <radhermit@gentoo.org> +pip-1.1.ebuild:
+ Version bump.
16 Feb 2012; Agostino Sarubbo <ago@gentoo.org> pip-1.0.2.ebuild:
Stable for amd64, wrt bug #403871
diff --git a/dev-python/pip/pip-1.1.ebuild b/dev-python/pip/pip-1.1.ebuild
new file mode 100644
index 000000000000..d1e570d49408
--- /dev/null
+++ b/dev-python/pip/pip-1.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/pip-1.1.ebuild,v 1.1 2012/02/17 06:52:03 radhermit Exp $
+
+EAPI="4"
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit bash-completion-r1 distutils eutils
+
+DESCRIPTION="Installs python packages -- replacement for easy_install"
+HOMEPAGE="http://www.pip-installer.org/ http://pypi.python.org/pypi/pip/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="zsh-completion"
+
+RDEPEND="dev-python/setuptools"
+DEPEND="${RDEPEND}"
+
+# Tests require a couple libraries not yet in the tree, aren't bundled with
+# the default tarball from pypi, and have a couple failures anyway
+RESTRICT="test"
+
+DOCS="AUTHORS.txt docs/*.txt"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.1-unversioned.patch
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+ COMPLETION="${T}/completion.tmp"
+
+ "$(PYTHON -f)" pip/runner.py completion --bash > "${COMPLETION}" || die
+ newbashcomp "${COMPLETION}" ${PN}
+
+ if use zsh-completion ; then
+ "$(PYTHON -f)" pip/runner.py completion --zsh > "${COMPLETION}" || die
+ insinto /usr/share/zsh/site-functions
+ newins "${COMPLETION}" _pip
+ fi
+}