summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/libxml/ChangeLog9
-rw-r--r--dev-ruby/libxml/libxml-1.1.3-r1.ebuild39
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-ruby/libxml/ChangeLog b/dev-ruby/libxml/ChangeLog
index b25030c353e0..4e0b65f98dac 100644
--- a/dev-ruby/libxml/ChangeLog
+++ b/dev-ruby/libxml/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/libxml
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/ChangeLog,v 1.30 2009/12/09 19:33:06 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/ChangeLog,v 1.31 2009/12/15 20:00:53 flameeyes Exp $
+
+*libxml-1.1.3-r1 (15 Dec 2009)
+
+ 15 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ +libxml-1.1.3-r1.ebuild:
+ Bump to ruby-fakegem (and yes, the tests crash Ruby here as well, but it's
+ not a regression).
09 Dec 2009; Hans de Graaff <graaff@gentoo.org> -libxml-0.5.4.ebuild:
Remove old version.
diff --git a/dev-ruby/libxml/libxml-1.1.3-r1.ebuild b/dev-ruby/libxml/libxml-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..0c7240302687
--- /dev/null
+++ b/dev-ruby/libxml/libxml-1.1.3-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/libxml-1.1.3-r1.ebuild,v 1.1 2009/12/15 20:00:53 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_NAME="libxml-ruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README CHANGES"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby libxml with a user friendly API, akin to REXML, but feature complete and significantly faster."
+HOMEPAGE="http://libxml.rubyforge.org"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/libxml2-2.6.6"
+DEPEND="${RDEPEND}"
+
+each_ruby_compile() {
+ pushd ext/libxml
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+
+ emake || die "make extension failed"
+ popd
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ ruby_fakegem_newins ext/libxml/libxml_ruby.so lib/libxml_ruby.so
+}