summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/console-tools/console-tools-0.2.3-r3.ebuild53
-rw-r--r--sys-apps/console-tools/console-tools-0.2.3-r4.ebuild31
-rw-r--r--sys-apps/console-tools/console-tools-0.3.2.ebuild15
-rw-r--r--sys-apps/console-tools/files/digest-console-tools-0.2.3-r31
4 files changed, 20 insertions, 80 deletions
diff --git a/sys-apps/console-tools/console-tools-0.2.3-r3.ebuild b/sys-apps/console-tools/console-tools-0.2.3-r3.ebuild
deleted file mode 100644
index b73aec48e582..000000000000
--- a/sys-apps/console-tools/console-tools-0.2.3-r3.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/console-tools/console-tools-0.2.3-r3.ebuild,v 1.15 2003/06/21 21:19:39 drobbins Exp $
-
-IUSE="nls"
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Console and font utilities"
-SRC_URI="mirror://sourceforge/lct/${P}.tar.gz"
-HOMEPAGE="http://lct.sourceforge.net/"
-KEYWORDS="x86 amd64 mips"
-SLOT="0"
-LICENSE="GPL-2"
-
-DEPEND="virtual/glibc
- nls? ( sys-devel/gettext )"
-RDEPEND="virtual/glibc"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- patch -p1 < ${FILESDIR}/${P}.patch
-
- patch -p0 < ${FILESDIR}/${P}-po-Makefile.in.in-gentoo.diff
-}
-
-src_compile() {
- local myconf
-
- [ "$DEBUG" ] && myconf="--enable-debugging"
- [ -z "`use nls`" ] && myconf="${myconf} --disable-nls"
-
- econf --host=${CHOST} ${myconf} || die "econf died"
- make ${MAKEOPTS} all || die "make died"
-}
-
-src_install() {
- # DESTDIR does not work correct
- make DESTDIR=${D} install || die "make install died"
-
- dodoc BUGS COPYING* CREDITS ChangeLog NEWS README RELEASE TODO
- docinto txt
- dodoc doc/*.txt doc/README.*
- docinto sgml
- dodoc doc/*.sgml
- docinto txt/contrib
- dodoc doc/contrib/*
- docinto txt/dvorak
- dodoc doc/dvorak/*
- docinto txt/file-formats
- dodoc doc/file-formats/*
- doman doc/man/*.[1-8]
-}
diff --git a/sys-apps/console-tools/console-tools-0.2.3-r4.ebuild b/sys-apps/console-tools/console-tools-0.2.3-r4.ebuild
index 981972341af0..56d1a9acb334 100644
--- a/sys-apps/console-tools/console-tools-0.2.3-r4.ebuild
+++ b/sys-apps/console-tools/console-tools-0.2.3-r4.ebuild
@@ -1,16 +1,15 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/console-tools/console-tools-0.2.3-r4.ebuild,v 1.18 2003/06/21 21:19:39 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/console-tools/console-tools-0.2.3-r4.ebuild,v 1.19 2003/08/03 04:34:12 vapier Exp $
-IUSE="nls"
-
-S=${WORKDIR}/${P}
DESCRIPTION="Console and font utilities"
-SRC_URI="mirror://sourceforge/lct/${P}.tar.gz"
HOMEPAGE="http://lct.sourceforge.net/"
-KEYWORDS="x86 amd64 ppc sparc ~alpha mips"
-SLOT="0"
+SRC_URI="mirror://sourceforge/lct/${P}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64 ppc sparc ~alpha mips"
+IUSE="nls debug"
DEPEND="virtual/glibc
sys-devel/autoconf sys-devel/automake sys-devel/libtool
@@ -20,8 +19,8 @@ RDEPEND="virtual/glibc"
src_unpack() {
unpack ${A}
cd ${S}
- patch -p1 < ${FILESDIR}/${P}.patch || die
- patch -p0 < ${FILESDIR}/${P}-po-Makefile.in.in-gentoo.diff || die
+ epatch ${FILESDIR}/${P}.patch
+ epatch ${FILESDIR}/${P}-po-Makefile.in.in-gentoo.diff
aclocal || die
libtoolize --force -c || die
autoheader || die
@@ -30,15 +29,11 @@ src_unpack() {
}
src_compile() {
- local myconf=""
- [ "$DEBUG" ] && myconf="--enable-debugging"
- [ -z "`use nls`" ] && myconf="${myconf} --disable-nls"
-
- ./configure --prefix=/usr \
- --mandir=/usr/share/man \
- --host=${CHOST} \
- ${myconf} || die
- make $MAKEOPTS all || die
+ econf \
+ `use_enable nls` \
+ `use_enable debug debugging` \
+ || die
+ emake all || die
}
src_install() {
diff --git a/sys-apps/console-tools/console-tools-0.3.2.ebuild b/sys-apps/console-tools/console-tools-0.3.2.ebuild
index fe5d0b1f3cc0..b479a4b0a40f 100644
--- a/sys-apps/console-tools/console-tools-0.3.2.ebuild
+++ b/sys-apps/console-tools/console-tools-0.3.2.ebuild
@@ -1,19 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/console-tools/console-tools-0.3.2.ebuild,v 1.5 2003/06/21 21:19:39 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/console-tools/console-tools-0.3.2.ebuild,v 1.6 2003/08/03 04:34:12 vapier Exp $
-inherit libtool eutils
+inherit libtool
-IUSE="nls"
-
-S=${WORKDIR}/${P}
DESCRIPTION="Console and font utilities"
HOMEPAGE="http://lct.sourceforge.net/"
SRC_URI="mirror://sourceforge/lct/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 amd64 ~ppc ~sparc ~alpha ~mips"
+IUSE="nls debug"
DEPEND="sys-devel/autoconf
>=sys-apps/sed-4
@@ -38,8 +36,9 @@ src_compile() {
[ -z "`use nls`" ] && myconf="${myconf} --disable-nls"
econf \
- ${myconf} || die
- make ${MAKEOPTS} all || die
+ `use_enable nls` \
+ `use_enable debug debugging` \
+ emake all || die
}
src_install() {
diff --git a/sys-apps/console-tools/files/digest-console-tools-0.2.3-r3 b/sys-apps/console-tools/files/digest-console-tools-0.2.3-r3
deleted file mode 100644
index c6222ed5b96f..000000000000
--- a/sys-apps/console-tools/files/digest-console-tools-0.2.3-r3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 983d4586a791b3fdfa0fbeff76aadf43 console-tools-0.2.3.tar.gz 668665