summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/win4lin/ChangeLog7
-rw-r--r--app-emulation/win4lin/files/digest-win4lin-4.0.221
-rw-r--r--app-emulation/win4lin/files/digest-win4lin-5.0.11
-rw-r--r--app-emulation/win4lin/files/registerme.sh7
-rw-r--r--app-emulation/win4lin/win4lin-4.0.22.ebuild81
-rw-r--r--app-emulation/win4lin/win4lin-5.0.1.ebuild88
6 files changed, 182 insertions, 3 deletions
diff --git a/app-emulation/win4lin/ChangeLog b/app-emulation/win4lin/ChangeLog
index 64c3c7cbd871..804ce0ab9fa3 100644
--- a/app-emulation/win4lin/ChangeLog
+++ b/app-emulation/win4lin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/win4lin
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/win4lin/ChangeLog,v 1.7 2003/04/13 12:46:05 bass Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/win4lin/ChangeLog,v 1.8 2003/06/03 22:29:28 bass Exp $
+
+*win4lin-5.0.1 (03 Jun 2003)
+
+ 03 Jun 2003; J.Alberto Suárez L. <bass@gentoo.org> win4lin-5.0.1.ebuild:
+ New version and new evaluation code.
*win4lin-4.0.20 (13 Apr 2003)
diff --git a/app-emulation/win4lin/files/digest-win4lin-4.0.22 b/app-emulation/win4lin/files/digest-win4lin-4.0.22
new file mode 100644
index 000000000000..d1e4a60cf1f1
--- /dev/null
+++ b/app-emulation/win4lin/files/digest-win4lin-4.0.22
@@ -0,0 +1 @@
+MD5 fe4f7cbcff4c8f81833f52cf1be1ed84 Win4Lin-5.3.22a-d.i386.rpm 4470029
diff --git a/app-emulation/win4lin/files/digest-win4lin-5.0.1 b/app-emulation/win4lin/files/digest-win4lin-5.0.1
new file mode 100644
index 000000000000..afd867e021a0
--- /dev/null
+++ b/app-emulation/win4lin/files/digest-win4lin-5.0.1
@@ -0,0 +1 @@
+MD5 bda98e6eb107a838610b3cb63ead4f6b Win4Lin-5.5.1d-d.i386.rpm 4841688
diff --git a/app-emulation/win4lin/files/registerme.sh b/app-emulation/win4lin/files/registerme.sh
index d2a52d7953d5..aa57b5f60369 100644
--- a/app-emulation/win4lin/files/registerme.sh
+++ b/app-emulation/win4lin/files/registerme.sh
@@ -1,10 +1,13 @@
#!/bin/sh
echo 'Your license evaluation code is:'
+echo '-> Win4Lin 4.x:'
echo ' 1w4e053x-n0aaf8-7tw9-587j-h47j-d6'
+echo '-> Win4Lin 5.x'
+echo ' 1w5e055x-n0ca34-xjhx-xx3c-4c3c-73'
echo
-echo 'Remember you need do this like root.'
-echo 'copy it and press a key'
+echo 'Remember you need do this in root mode.'
+echo 'copy it and press a key to start the reg.'
read
sh /opt/win4lin/bin/ask_license.sh
diff --git a/app-emulation/win4lin/win4lin-4.0.22.ebuild b/app-emulation/win4lin/win4lin-4.0.22.ebuild
new file mode 100644
index 000000000000..f3535914ce8a
--- /dev/null
+++ b/app-emulation/win4lin/win4lin-4.0.22.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/win4lin/win4lin-4.0.22.ebuild,v 1.1 2003/06/03 22:29:28 bass Exp $
+
+IUSE="doc"
+
+MY_P=Win4Lin-5.3.22a-d.i386
+
+S=${WORKDIR}
+DESCRIPTION="Win4Lin allows you run Windows applications somewhat natively
+under linux."
+HOMEPAGE="http://www.netraverse.com/"
+SRC_URI="mirror://gentoo/${MY_P}.rpm"
+# doc? ( https://www.netraverse.com/support/docs/Win4Lin-4.0.0-manual.pdf )"
+
+SLOT="0"
+LICENSE="NeTraverse"
+KEYWORDS="~x86"
+
+DEPEND="app-arch/rpm2targz
+ sys-kernel/win4lin-sources"
+
+src_unpack() {
+ rpm2targz ${DISTDIR}/${MY_P}.rpm
+ tar zxf ${WORKDIR}/${MY_P}.tar.gz
+}
+
+src_compile() {
+ einfo "nothing to compile; binary package."
+}
+
+src_install() {
+ mv ${S}/opt ${D}
+ mv ${S}/etc ${D}
+ cp ${FILESDIR}/registerme.sh ${D}/opt/win4lin/
+ cp ${FILESDIR}/win4lin.initd ${D}/opt/win4lin/win4lin.initd
+
+ if [ -n "`use doc`" ]
+ then
+ dodoc ${DISTDIR}/Win4Lin-4.0.0-manual.pdf
+ fi
+}
+
+
+pkg_postinst() {
+ /opt/win4lin/postinst_rpm.sh
+ echo "LICENSE_CODE=1w4e053x-n0aaf8-7tw9-587j-h47j-d6" > /var/win4lin/install/license.lic
+ einfo "If this is a new Win4Lin Install you will need to run the following command"
+ einfo "ebuild /var/db/pkg/app-emulation/${PF}/${PF}.ebuild config"
+ einfo "to install the windows setup files. You will need your Windows cdrom in the "
+ einfo "drive in order to complete this step."
+}
+
+
+pkg_prerm() {
+ /opt/win4lin/remove_rpm.sh
+}
+
+pkg_config() {
+ loadwindowsCD cddevice /dev/cdrom
+# ln -s /etc/rc.d/init.d/Win4Lin /etc/init.d/Win4Lin
+ cp /opt/win4lin/win4lin.initd /etc/init.d/Win4Lin
+ #put debugging stuff here
+ if [ ${?} -eq "0" ]; then
+ einfo "You can now run the command \"installwindows\" from an xterm "
+ einfo "as a non-root user to install a personal copy of Windows that Win4Lin "
+ einfo "will use for that user."
+ einfo
+ einfo "Win4Lin is a commercial product, you now are using a evaluation-license"
+ einfo "for 15 days evaluation. If you want a extra 15 days of evaluation you"
+ einfo 'must run "sh /opt/win4lin/registerme.sh"'
+ einfo
+ einfo 'You can help Gentoo Linux and obatin a full license at a discont offer'
+ einfo 'for gentoo users in http://www.netraverse.com/gentoo.htm'
+ einfo 'Netraverse donate to Gentoo Linux a percent of each purchase.'
+ einfo 'Thanks Netaverse.'
+ einfo
+ einfo 'Remember, you must do "/etc/init.d/Win4Lin start" before start w4l'
+ einfo 'Also you can add it to default boot "rc-update add Win4Lin default"'
+ fi
+}
diff --git a/app-emulation/win4lin/win4lin-5.0.1.ebuild b/app-emulation/win4lin/win4lin-5.0.1.ebuild
new file mode 100644
index 000000000000..c68ea818a80f
--- /dev/null
+++ b/app-emulation/win4lin/win4lin-5.0.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/win4lin/win4lin-5.0.1.ebuild,v 1.1 2003/06/03 22:29:28 bass Exp $
+
+IUSE="doc"
+
+MY_P=Win4Lin-5.5.1d-d.i386
+
+S=${WORKDIR}
+DESCRIPTION="Win4Lin allows you run Windows applications somewhat natively
+under linux."
+HOMEPAGE="http://www.netraverse.com/"
+SRC_URI="mirror://gentoo/${MY_P}.rpm"
+# doc? ( https://www.netraverse.com/support/docs/Win4Lin-4.0.0-manual.pdf )"
+
+SLOT="0"
+LICENSE="NeTraverse"
+KEYWORDS="x86"
+
+DEPEND="app-arch/rpm2targz
+ virtual/winkernel"
+RDEPEND="!<=app/emulation/win4lin-4.0.22"
+
+src_unpack() {
+ rpm2targz ${DISTDIR}/${MY_P}.rpm
+ tar zxf ${WORKDIR}/${MY_P}.tar.gz
+}
+
+src_compile() {
+ einfo "nothing to compile; binary package."
+ einfo "Remember you need a kernel patched like"
+ einfo "win4lin-sources or gs-sources."
+}
+
+src_install() {
+ mv ${S}/opt ${D}
+ mv ${S}/etc ${D}
+ cp ${FILESDIR}/registerme.sh ${D}/opt/win4lin/
+ cp ${FILESDIR}/win4lin.initd ${D}/opt/win4lin/
+
+# if [ -n "`use doc`" ]
+# then
+# dodoc ${DISTDIR}/Win4Lin-4.0.0-manual.pdf
+# fi
+}
+
+
+pkg_postinst() {
+ /opt/win4lin/postinst_rpm.sh
+ echo "LICENSE_CODE=1w5e055x-n0ca34-xjhx-xx3c-4c3c-73" > /var/win4lin/install/license.lic
+ einfo "If this is a new Win4Lin Install you will need to run the following command"
+ einfo "ebuild /var/db/pkg/app-emulation/${PF}/${PF}.ebuild config"
+ einfo "to install the windows setup files. You will need your Windows cdrom in the "
+ einfo "drive in order to complete this step."
+ einfo "============"
+ einfo "If this is an upgrade 4.x to 5.x the trial license code isn valid,"
+ einfo "you need register it in NeTraverse, or unemerge ALL Win4Lin files."
+
+}
+
+
+pkg_prerm() {
+ /opt/win4lin/remove_rpm.sh
+}
+
+pkg_config() {
+ loadwindowsCD cddevice /dev/cdrom
+# ln -s /etc/rc.d/init.d/Win4Lin /etc/init.d/Win4Lin
+ cp /opt/win4lin/win4lin.initd /etc/init.d/Win4Lin
+ #put debugging stuff here
+ if [ ${?} -eq "0" ]; then
+ einfo "You can now run the command \"installwindows\" from an xterm "
+ einfo "as a non-root user to install a personal copy of Windows that Win4Lin "
+ einfo "will use for that user."
+ einfo
+ einfo "Win4Lin is a commercial product, you now are using a evaluation-license"
+ einfo "for 15 days evaluation. If you want a extra 15 days of evaluation you"
+ einfo 'must run "sh /opt/win4lin/registerme.sh"'
+ einfo
+ einfo 'You can help Gentoo Linux and obatin a full license at a discont offer'
+ einfo 'for gentoo users in http://www.netraverse.com/gentoo.htm'
+ einfo 'Netraverse donate to Gentoo Linux a percent of each purchase.'
+ einfo 'Thanks Netaverse.'
+ einfo
+ einfo 'Remember, you must do "/etc/init.d/Win4Lin start" before start w4l'
+ einfo 'Also you can add it to default boot "rc-update add Win4Lin default"'
+ fi
+}