summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail-filter/popfile/popfile-1.1.1.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/mail-filter/popfile/popfile-1.1.1.ebuild b/mail-filter/popfile/popfile-1.1.1.ebuild
index df51b9005be6..3caea3775027 100644
--- a/mail-filter/popfile/popfile-1.1.1.ebuild
+++ b/mail-filter/popfile/popfile-1.1.1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/popfile/popfile-1.1.1.ebuild,v 1.1 2010/01/07 16:05:18 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/popfile/popfile-1.1.1.ebuild,v 1.2 2010/01/07 16:12:13 ssuominen Exp $
+EAPI=2
inherit eutils
DESCRIPTION="Anti-spam bayesian filter"
@@ -32,6 +33,13 @@ RDEPEND="virtual/perl-Digest-MD5
DEPEND="app-arch/unzip"
+src_prepare() {
+ local f
+ for f in `find ./ -type f`; do
+ edos2unix "${f}"
+ done
+}
+
src_install() {
dodoc *.change*
rm -rf *.change* license
@@ -39,11 +47,6 @@ src_install() {
insinto /usr/share/${PN}
doins -r * || die
- local f
- for f in `find "${D}"/usr/share/${PN} -type f`; do
- edos2unix "${f}"
- done
-
fperms 755 /usr/share/${PN}/*.pl
dosbin "${FILESDIR}"/${PN} || die