summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--incoming/pygame-1.2.ebuild10
-rw-r--r--incoming/sdl-ttf-2.0.3.ebuild26
2 files changed, 31 insertions, 5 deletions
diff --git a/incoming/pygame-1.2.ebuild b/incoming/pygame-1.2.ebuild
index 5f9acabc5250..7cc21d3de5bf 100644
--- a/incoming/pygame-1.2.ebuild
+++ b/incoming/pygame-1.2.ebuild
@@ -12,8 +12,8 @@ SRC_URI="http://www.pygame.org/ftp/${P}.tar.gz"
HOMEPAGE="http://www.pygame.org/"
#build-time dependencies
-DEPEND=">=media-libs/libsdl-1.2.0
- >=dev-lang/python-2.0
+DEPEND="virtual/python
+ >=media-libs/libsdl-1.2.0
>=media-libs/sdl-ttf-2.0.3
>=media-libs/sdl-image-1.2.0
>=media-libs/sdl-mixer-1.2.0
@@ -21,11 +21,11 @@ DEPEND=">=media-libs/libsdl-1.2.0
>=media-libs/smpeg-0.4.4"
src_compile() {
- try python setup.py build
+ python setup.py build || die
}
src_install () {
- echo ${D}
- try python setup.py install --prefix=${D}/usr
+ python setup.py install --prefix=${D}/usr || die
+ dodoc README.TXT WHATSNEW
}
diff --git a/incoming/sdl-ttf-2.0.3.ebuild b/incoming/sdl-ttf-2.0.3.ebuild
new file mode 100644
index 000000000000..76bf43021143
--- /dev/null
+++ b/incoming/sdl-ttf-2.0.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author David Creswick <davidc@sat.net>
+# /home/cvsroot/gentoo-x86/skel.build,v 1.7 2001/08/25 21:15:08 chadh Exp
+
+${S}=${WORKDIR}/SDL_ttf-${PV}
+
+DESCRIPTION="library that allows you to use TrueType fonts in SDL applications"
+
+SRC_URI="http://www.libsdl.org/projects/SDL_ttf/release/SDL_ttf-2.0.3.tar.gz"
+
+HOMEPAGE="http://www.libsdl.org/projects/SDL_ttf/"
+
+#build-time dependencies
+DEPEND=">=media-libs/libsdl-1.2
+ >=media-libs/freetype-2.0.1"
+
+src_compile() {
+ ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST} || die
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr install || die
+ dodoc CHANGES COPYING README
+}