summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-perl/MusicBrainz-DiscID/ChangeLog8
-rw-r--r--dev-perl/MusicBrainz-DiscID/MusicBrainz-DiscID-0.30.0-r1.ebuild14
2 files changed, 18 insertions, 4 deletions
diff --git a/dev-perl/MusicBrainz-DiscID/ChangeLog b/dev-perl/MusicBrainz-DiscID/ChangeLog
index e997d943f8a6..c044a0ffea23 100644
--- a/dev-perl/MusicBrainz-DiscID/ChangeLog
+++ b/dev-perl/MusicBrainz-DiscID/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-perl/MusicBrainz-DiscID
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/MusicBrainz-DiscID/ChangeLog,v 1.8 2014/08/23 22:01:44 axs Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/MusicBrainz-DiscID/ChangeLog,v 1.9 2015/03/19 17:26:47 monsieurp Exp $
+
+ 19 Mar 2015; Patrice Clement <monsieurp@gentoo.org>
+ MusicBrainz-DiscID-0.30.0-r1.ebuild:
+ Remove bad character in DiscID.pm for tests to pass. Fix bug 526260.
*MusicBrainz-DiscID-0.30.0-r1 (23 Aug 2014)
diff --git a/dev-perl/MusicBrainz-DiscID/MusicBrainz-DiscID-0.30.0-r1.ebuild b/dev-perl/MusicBrainz-DiscID/MusicBrainz-DiscID-0.30.0-r1.ebuild
index d046c0fec96c..dd297a34773d 100644
--- a/dev-perl/MusicBrainz-DiscID/MusicBrainz-DiscID-0.30.0-r1.ebuild
+++ b/dev-perl/MusicBrainz-DiscID/MusicBrainz-DiscID-0.30.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/MusicBrainz-DiscID/MusicBrainz-DiscID-0.30.0-r1.ebuild,v 1.1 2014/08/23 22:01:44 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/MusicBrainz-DiscID/MusicBrainz-DiscID-0.30.0-r1.ebuild,v 1.2 2015/03/19 17:26:47 monsieurp Exp $
EAPI=5
@@ -32,6 +32,16 @@ PATCHES=(
"${WORKDIR}"/${MY_PN:-${PN}}-patch
)
+src_prepare() {
+ # Quick n dirty fix but does the job.
+ ebegin 'Patching lib/MusicBrainz/DiscID.pm'
+ # There's a dangling non-ASCII character that causes perldoc to fail on
+ # parsing the .pm and hence, fail tests. We should file a bug upstream.
+ perl -i'' -npe "s/don.. specify/don't specify/g;" lib/MusicBrainz/DiscID.pm
+ eend $?
+
+ perl-module_src_prepare
+}
src_install() {
perl-module_src_install