summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/scrapy/ChangeLog9
-rw-r--r--dev-python/scrapy/scrapy-0.18.0-r1.ebuild68
-rw-r--r--dev-python/scrapy/scrapy-0.18.0.ebuild62
-rw-r--r--dev-python/scrapy/scrapy-0.18.1.ebuild68
-rw-r--r--dev-python/scrapy/scrapy-0.18.2.ebuild65
-rw-r--r--dev-python/scrapy/scrapy-0.18.3.ebuild65
-rw-r--r--dev-python/scrapy/scrapy-0.20.0.ebuild (renamed from dev-python/scrapy/scrapy-0.18.4.ebuild)17
7 files changed, 16 insertions, 338 deletions
diff --git a/dev-python/scrapy/ChangeLog b/dev-python/scrapy/ChangeLog
index 314a3154e6ae..dbd208cabdc5 100644
--- a/dev-python/scrapy/ChangeLog
+++ b/dev-python/scrapy/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/scrapy
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scrapy/ChangeLog,v 1.21 2014/06/09 08:50:30 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scrapy/ChangeLog,v 1.22 2014/06/25 04:57:58 idella4 Exp $
+
+*scrapy-0.20.0 (25 Jun 2014)
+
+ 25 Jun 2014; Ian Delaney <idella4@gentoo.org> +scrapy-0.20.0.ebuild,
+ -scrapy-0.18.0-r1.ebuild, -scrapy-0.18.0.ebuild, -scrapy-0.18.1.ebuild,
+ -scrapy-0.18.2.ebuild, -scrapy-0.18.3.ebuild, -scrapy-0.18.4.ebuild:
+ bump; update deps, rm old
*scrapy-0.19.0 (09 Jun 2014)
diff --git a/dev-python/scrapy/scrapy-0.18.0-r1.ebuild b/dev-python/scrapy/scrapy-0.18.0-r1.ebuild
deleted file mode 100644
index 996cb59872cf..000000000000
--- a/dev-python/scrapy/scrapy-0.18.0-r1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scrapy/scrapy-0.18.0-r1.ebuild,v 1.1 2013/12/06 05:44:16 patrick Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="sqlite(+)"
-
-inherit vcs-snapshot distutils-r1
-
-DESCRIPTION="A high-level Python Screen Scraping framework"
-HOMEPAGE="http://scrapy.org http://pypi.python.org/pypi/Scrapy/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="boto doc examples ibl test ssl"
-PYTHON_MODNAME="scrapy scrapyd"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/boto[${PYTHON_USEDEP}]
- dev-python/queuelib[${PYTHON_USEDEP}]
- dev-python/django[${PYTHON_USEDEP}]
- net-ftp/vsftpd
- )"
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- dev-libs/libxml2[python,${PYTHON_USEDEP}]
- boto? ( dev-python/boto[${PYTHON_USEDEP}] )
- virtual/python-imaging[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- ibl? ( dev-python/numpy[${PYTHON_USEDEP}] )
- ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/twisted-core
- dev-python/twisted-conch
- dev-python/twisted-mail
- dev-python/twisted-web
- >=dev-python/w3lib-1.1[${PYTHON_USEDEP}]
- "
-
-src_compile() {
- distutils-r1_src_compile
-
- if use doc; then
- emake -C docs html || die "emake html failed"
- fi
-}
-
-python_test() {
- PYTHONPATH="${PWD}" bin/runtests.sh || die
-}
-
-src_install() {
- distutils-r1_src_install
- if use doc; then
- dohtml -r "${S}"/docs/build/html/
- fi
- if use examples; then
- insinto /usr/share/doc/"${PF}"/examples
- doins -r "${S}"/examples/*
- fi
-}
diff --git a/dev-python/scrapy/scrapy-0.18.0.ebuild b/dev-python/scrapy/scrapy-0.18.0.ebuild
deleted file mode 100644
index 4b654a5c068c..000000000000
--- a/dev-python/scrapy/scrapy-0.18.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scrapy/scrapy-0.18.0.ebuild,v 1.1 2013/11/22 07:51:55 patrick Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_{6,7} )
-PYTHON_REQ_USE="sqlite(+)"
-
-inherit vcs-snapshot distutils-r1
-
-DESCRIPTION="A high-level Python Screen Scraping framework"
-HOMEPAGE="http://scrapy.org http://pypi.python.org/pypi/Scrapy/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="boto doc examples ibl test ssl"
-PYTHON_MODNAME="scrapy scrapyd"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/django[${PYTHON_USEDEP}]
- net-ftp/vsftpd
- )"
-RDEPEND="dev-libs/libxml2[python,${PYTHON_USEDEP}]
- boto? ( dev-python/boto[${PYTHON_USEDEP}] )
- virtual/python-imaging[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- ibl? ( dev-python/numpy[${PYTHON_USEDEP}] )
- ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/twisted-core
- dev-python/twisted-conch
- dev-python/twisted-mail
- dev-python/twisted-web
- >=dev-python/w3lib-1.1[${PYTHON_USEDEP}]"
-
-src_compile() {
- distutils-r1_src_compile
-
- if use doc; then
- emake -C docs html || die "emake html failed"
- fi
-}
-
-python_test() {
- PYTHONPATH="${PWD}" bin/runtests.sh
-}
-
-src_install() {
- distutils-r1_src_install
- if use doc; then
- dohtml -r "${S}"/docs/build/html/
- fi
- if use examples; then
- insinto /usr/share/doc/"${PF}"/examples
- doins -r "${S}"/examples/*
- fi
-}
diff --git a/dev-python/scrapy/scrapy-0.18.1.ebuild b/dev-python/scrapy/scrapy-0.18.1.ebuild
deleted file mode 100644
index ee09e741b633..000000000000
--- a/dev-python/scrapy/scrapy-0.18.1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scrapy/scrapy-0.18.1.ebuild,v 1.1 2014/05/03 07:34:51 patrick Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="sqlite(+)"
-
-inherit vcs-snapshot distutils-r1
-
-DESCRIPTION="A high-level Python Screen Scraping framework"
-HOMEPAGE="http://scrapy.org http://pypi.python.org/pypi/Scrapy/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="boto doc examples ibl test ssl"
-PYTHON_MODNAME="scrapy scrapyd"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/boto[${PYTHON_USEDEP}]
- dev-python/queuelib[${PYTHON_USEDEP}]
- dev-python/django[${PYTHON_USEDEP}]
- net-ftp/vsftpd
- )"
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- dev-libs/libxml2[python,${PYTHON_USEDEP}]
- boto? ( dev-python/boto[${PYTHON_USEDEP}] )
- virtual/python-imaging[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- ibl? ( dev-python/numpy[${PYTHON_USEDEP}] )
- ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/twisted-core
- dev-python/twisted-conch
- dev-python/twisted-mail
- dev-python/twisted-web
- >=dev-python/w3lib-1.1[${PYTHON_USEDEP}]
- "
-
-src_compile() {
- distutils-r1_src_compile
-
- if use doc; then
- emake -C docs html || die "emake html failed"
- fi
-}
-
-python_test() {
- PYTHONPATH="${PWD}" bin/runtests.sh || die
-}
-
-src_install() {
- distutils-r1_src_install
- if use doc; then
- dohtml -r "${S}"/docs/build/html/
- fi
- if use examples; then
- insinto /usr/share/doc/"${PF}"/examples
- doins -r "${S}"/examples/*
- fi
-}
diff --git a/dev-python/scrapy/scrapy-0.18.2.ebuild b/dev-python/scrapy/scrapy-0.18.2.ebuild
deleted file mode 100644
index 77dc5398cc69..000000000000
--- a/dev-python/scrapy/scrapy-0.18.2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scrapy/scrapy-0.18.2.ebuild,v 1.1 2014/05/20 02:37:26 idella4 Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="sqlite(+)"
-
-inherit vcs-snapshot distutils-r1
-
-DESCRIPTION="A high-level Python Screen Scraping framework"
-HOMEPAGE="http://scrapy.org http://pypi.python.org/pypi/Scrapy/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="boto doc ibl test ssl"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]
- dev-libs/libxml2[python,${PYTHON_USEDEP}]
- virtual/python-imaging[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- ibl? ( dev-python/numpy[${PYTHON_USEDEP}] )
- ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
- boto? ( dev-python/boto[${PYTHON_USEDEP}] )
- >=dev-python/twisted-core-8.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-conch-8.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-mail-8.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-web-8.0[${PYTHON_USEDEP}]
- >=dev-python/w3lib-1.2[${PYTHON_USEDEP}]
- dev-python/queuelib[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( ${RDEPEND}
- dev-python/boto[${PYTHON_USEDEP}]
- dev-python/django[${PYTHON_USEDEP}]
- net-ftp/vsftpd
- dev-python/pyopenssl[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Skip failing tests; https://github.com/scrapy/scrapy/issues/725
- sed -e s':test_validation:_&:' \
- -i scrapy/tests/test_djangoitem/__init__.py || die
- sed -e s':test_process_parallel_failure:_&:' \
- -i scrapy/tests/test_utils_defer.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- PYTHONPATH="${S}" emake -C docs html || die "emake html failed"
- fi
-}
-
-python_test() {
- PYTHONPATH="${PWD}" bin/runtests.sh || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/scrapy/scrapy-0.18.3.ebuild b/dev-python/scrapy/scrapy-0.18.3.ebuild
deleted file mode 100644
index e061a5592cfa..000000000000
--- a/dev-python/scrapy/scrapy-0.18.3.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scrapy/scrapy-0.18.3.ebuild,v 1.1 2014/05/26 07:34:16 patrick Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="sqlite(+)"
-
-inherit vcs-snapshot distutils-r1
-
-DESCRIPTION="A high-level Python Screen Scraping framework"
-HOMEPAGE="http://scrapy.org http://pypi.python.org/pypi/Scrapy/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="boto doc ibl test ssl"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]
- dev-libs/libxml2[python,${PYTHON_USEDEP}]
- virtual/python-imaging[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- ibl? ( dev-python/numpy[${PYTHON_USEDEP}] )
- ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
- boto? ( dev-python/boto[${PYTHON_USEDEP}] )
- >=dev-python/twisted-core-8.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-conch-8.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-mail-8.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-web-8.0[${PYTHON_USEDEP}]
- >=dev-python/w3lib-1.2[${PYTHON_USEDEP}]
- dev-python/queuelib[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( ${RDEPEND}
- dev-python/boto[${PYTHON_USEDEP}]
- dev-python/django[${PYTHON_USEDEP}]
- net-ftp/vsftpd
- dev-python/pyopenssl[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Skip failing tests; https://github.com/scrapy/scrapy/issues/725
- sed -e s':test_validation:_&:' \
- -i scrapy/tests/test_djangoitem/__init__.py || die
- sed -e s':test_process_parallel_failure:_&:' \
- -i scrapy/tests/test_utils_defer.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- PYTHONPATH="${S}" emake -C docs html || die "emake html failed"
- fi
-}
-
-python_test() {
- PYTHONPATH="${PWD}" bin/runtests.sh || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/scrapy/scrapy-0.18.4.ebuild b/dev-python/scrapy/scrapy-0.20.0.ebuild
index deb64cb01999..eb3cc6d94328 100644
--- a/dev-python/scrapy/scrapy-0.18.4.ebuild
+++ b/dev-python/scrapy/scrapy-0.20.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scrapy/scrapy-0.18.4.ebuild,v 1.1 2014/06/03 06:58:12 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scrapy/scrapy-0.20.0.ebuild,v 1.1 2014/06/25 04:57:58 idella4 Exp $
EAPI=5
@@ -25,12 +25,13 @@ RDEPEND="dev-python/six[${PYTHON_USEDEP}]
ibl? ( dev-python/numpy[${PYTHON_USEDEP}] )
ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
boto? ( dev-python/boto[${PYTHON_USEDEP}] )
- dev-python/twisted-core[${PYTHON_USEDEP}]
- dev-python/twisted-conch[${PYTHON_USEDEP}]
- dev-python/twisted-mail[${PYTHON_USEDEP}]
- dev-python/twisted-web[${PYTHON_USEDEP}]
+ >=dev-python/twisted-core-10.0.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-conch-10.0.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-mail-10.0.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-web-10.0.0[${PYTHON_USEDEP}]
>=dev-python/w3lib-1.2[${PYTHON_USEDEP}]
- dev-python/queuelib[${PYTHON_USEDEP}]"
+ dev-python/queuelib[${PYTHON_USEDEP}]
+ >=dev-python/cssselect-0.9[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
@@ -40,12 +41,10 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
net-ftp/vsftpd
dev-python/pillow[${PYTHON_USEDEP}] )"
-REQUIRED_USE="test? ( ssl )"
+REQUIRED_USE="test? ( ssl boto )"
python_prepare_all() {
# Skip failing tests; https://github.com/scrapy/scrapy/issues/725
- sed -e s':test_validation:_&:' \
- -i scrapy/tests/test_djangoitem/__init__.py || die
sed -e s':test_process_parallel_failure:_&:' \
-i scrapy/tests/test_utils_defer.py || die
distutils-r1_python_prepare_all