summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/jail/ChangeLog9
-rw-r--r--app-misc/jail/Manifest5
-rw-r--r--app-misc/jail/files/digest-jail-1.9-r21
-rw-r--r--app-misc/jail/files/multiuser-rsa.patch44
-rw-r--r--app-misc/jail/jail-1.9-r2.ebuild78
5 files changed, 135 insertions, 2 deletions
diff --git a/app-misc/jail/ChangeLog b/app-misc/jail/ChangeLog
index e9658049cec2..ebc96e7bd394 100644
--- a/app-misc/jail/ChangeLog
+++ b/app-misc/jail/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/jail
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/jail/ChangeLog,v 1.13 2004/07/10 11:27:10 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/jail/ChangeLog,v 1.14 2004/09/20 12:50:03 dragonheart Exp $
+
+*jail-1.9-r2 (20 Sep 2004)
+
+ 20 Sep 2004; Daniel Black <dragonheart@gentoo.org>
+ +files/multiuser-rsa.patch, +jail-1.9-r2.ebuild:
+ multiuser.patch added as per bug #64718 thanks to Greg Payne
+ <payne@uppercasedevelopment.com> and the patch author Cory Thomas
10 Jul 2004; Tom Martin <slarti@gentoo.org> jail-1.9-r1.ebuild:
Marked ~amd64.
diff --git a/app-misc/jail/Manifest b/app-misc/jail/Manifest
index 9bb64e888d00..f70a36160df0 100644
--- a/app-misc/jail/Manifest
+++ b/app-misc/jail/Manifest
@@ -1,6 +1,9 @@
-MD5 3f7e8deb5d28e3cd05c6ffe64f65cd04 jail-1.9-r1.ebuild 1990
MD5 c6d2f66e4ce487a69f3b7548f0d05e56 ChangeLog 1435
+MD5 3f7e8deb5d28e3cd05c6ffe64f65cd04 jail-1.9-r1.ebuild 1990
MD5 7cb2052e33c36db6bd09152de8166065 metadata.xml 750
+MD5 9bbc5e03843221389bd6b74a0c220954 jail-1.9-r2.ebuild 2027
MD5 e06c54745344bca0608e4ec56dfd0ed0 files/digest-jail-1.9-r1 59
MD5 0f9cdbda612ae4e1df19de25b045bf2d files/jail-gentoo.diff 3256
MD5 c3db70e66c86804965b502d3eb50dd2c files/wrongshell.patch 472
+MD5 c73e8af5993b3d8fda4852dde897b1f0 files/multiuser-rsa.patch 844
+MD5 e06c54745344bca0608e4ec56dfd0ed0 files/digest-jail-1.9-r2 59
diff --git a/app-misc/jail/files/digest-jail-1.9-r2 b/app-misc/jail/files/digest-jail-1.9-r2
new file mode 100644
index 000000000000..46db79f06e61
--- /dev/null
+++ b/app-misc/jail/files/digest-jail-1.9-r2
@@ -0,0 +1 @@
+MD5 d9c4ae58e658e8b13809399c69726154 jail_1.9.tar.gz 32994
diff --git a/app-misc/jail/files/multiuser-rsa.patch b/app-misc/jail/files/multiuser-rsa.patch
new file mode 100644
index 000000000000..e7c94e274ba3
--- /dev/null
+++ b/app-misc/jail/files/multiuser-rsa.patch
@@ -0,0 +1,44 @@
+--- jail.c 2004-09-19 23:48:14.000000000 -0500
++++ jail.c 2004-09-20 00:07:48.000000000 -0500
+@@ -115,6 +115,20 @@
+ #include "helpers.h"
+ #include "types.h"
+
++
++
++void make_jail_dir( char* dir )
++{
++ for( ; *dir != '\0'; ++dir )
++ {
++ if( *dir == '.' )
++ {
++ *dir = '\0';
++ break;
++ }
++ }
++}
++
+ //////////////////////////////////////////////////////////////////////////////
+ //
+ // main()
+@@ -211,6 +225,7 @@
+ fprintf(stderr,"jail: can't get passwd info for uid %d\n",uid);
+ exit(-1);
+ }
++ make_jail_dir(pwdent->dir);
+
+ //
+ // create the terminal devices here
+@@ -289,7 +304,6 @@
+ free(pwdent->dir);
+ pwdent->dir = tmp_str;
+
+-
+ #if DEBUG != 0
+ fprintf(stderr,"jail: doing chdir(%s)\n",pwdent->dir);
+ #endif
+@@ -494,4 +508,3 @@
+ return(-4);
+ }
+
+-
diff --git a/app-misc/jail/jail-1.9-r2.ebuild b/app-misc/jail/jail-1.9-r2.ebuild
new file mode 100644
index 000000000000..69e1cb2aea23
--- /dev/null
+++ b/app-misc/jail/jail-1.9-r2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/jail/jail-1.9-r2.ebuild,v 1.1 2004/09/20 12:50:03 dragonheart Exp $
+
+inherit eutils flag-o-matic
+
+S="${WORKDIR}/${PN}_1-9_stable"
+DESCRIPTION="Jail Chroot Project is a tool that builds a chrooted environment and automagically configures and builds all the required files, directories and libraries"
+HOMEPAGE="http://www.jmcresearch.com/projects/jail/"
+SRC_URI="mirror://sourceforge/jail/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="virtual/libc
+ >=sys-apps/sed-4"
+RDEPEND="dev-lang/perl
+ dev-util/strace"
+
+src_unpack() {
+ unpack ${PN}_${PV}.tar.gz
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-gentoo.diff || die "failed to apply patch"
+ epatch ${FILESDIR}/wrongshell.patch || die "failed to apply patch"
+ cd src
+ epatch ${FILESDIR}/multiuser-rsa.patch || die "failed to apply patch"
+}
+
+src_compile() {
+ # configuration files should be installed in /etc not /usr/etc
+ sed -i "s:\$4/etc:\${D}/etc:g" install.sh
+
+ # the destination directory should be /usr not /usr/local
+ cd ${S}/src
+ sed -i -e "s:usr/local:${D}/usr:g" \
+ -e "s:^COPT =.*:COPT = -Wl,-z,no:g" Makefile
+
+ # Below didn't work. Don't know why
+ #append-ldflags -Wl,-z,now
+ emake || die "make failed"
+}
+
+src_install() {
+ cd ${S}/src
+ einstall
+
+ # remove //var/tmp/portage/jail-1.9/image//usr from files
+ FILES="
+ ${D}/usr/bin/mkjailenv
+ ${D}/usr/bin/addjailsw
+ ${D}/usr/bin/addjailuser
+ ${D}/etc/jail.conf
+ ${D}/usr/lib/libjail.pm
+ ${D}/usr/lib/arch/generic/definitions
+ ${D}/usr/lib/arch/generic/functions
+ ${D}/usr/lib/arch/linux/definitions
+ ${D}/usr/lib/arch/linux/functions
+ ${D}/usr/lib/arch/freebsd/definitions
+ ${D}/usr/lib/arch/freebsd/functions
+ ${D}/usr/lib/arch/irix/definitions
+ ${D}/usr/lib/arch/irix/functions
+ ${D}/usr/lib/arch/solaris/definitions
+ ${D}/usr/lib/arch/solaris/functions"
+
+ for f in ${FILES}; do
+ # documentation says funtion 'dosed' is supposed to do this, but didn't know how to make it work :'(
+ # dosed ${file} || die "error in dosed"
+ sed -i "s:/${D}/usr:/usr:g" ${f}
+ done
+
+ cd ${D}/usr/lib
+ sed -i "s:/usr/etc:/etc:" libjail.pm
+
+ cd ${S}/doc
+ dodoc CHANGELOG INSTALL README SECURITY VERSION
+}