summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/twisted-names/ChangeLog8
-rw-r--r--dev-python/twisted-names/twisted-names-11.0.0.ebuild21
2 files changed, 28 insertions, 1 deletions
diff --git a/dev-python/twisted-names/ChangeLog b/dev-python/twisted-names/ChangeLog
index 381aca43100c..d1823c449ff0 100644
--- a/dev-python/twisted-names/ChangeLog
+++ b/dev-python/twisted-names/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/twisted-names
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-names/ChangeLog,v 1.56 2011/01/25 17:04:52 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-names/ChangeLog,v 1.57 2011/04/04 20:45:39 arfrever Exp $
+
+*twisted-names-11.0.0 (04 Apr 2011)
+
+ 04 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +twisted-names-11.0.0.ebuild:
+ Version bump.
25 Jan 2011; Jeroen Roovers <jer@gentoo.org> twisted-names-10.2.0.ebuild:
Stable for HPPA (bug #350894).
diff --git a/dev-python/twisted-names/twisted-names-11.0.0.ebuild b/dev-python/twisted-names/twisted-names-11.0.0.ebuild
new file mode 100644
index 000000000000..783f5dd7b720
--- /dev/null
+++ b/dev-python/twisted-names/twisted-names-11.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-names/twisted-names-11.0.0.ebuild,v 1.1 2011/04/04 20:45:39 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+MY_PACKAGE="Names"
+
+inherit twisted versionator
+
+DESCRIPTION="A Twisted DNS implementation"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="=dev-python/twisted-$(get_version_component_range 1-2)*"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="twisted/names twisted/plugins"