summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/dsniff/ChangeLog6
-rw-r--r--net-analyzer/dsniff/dsniff-2.3-r10.ebuild7
-rw-r--r--net-analyzer/dsniff/files/2.3-openssl.patch12
3 files changed, 23 insertions, 2 deletions
diff --git a/net-analyzer/dsniff/ChangeLog b/net-analyzer/dsniff/ChangeLog
index 0f7ddb6d3225..41d46c0ffffb 100644
--- a/net-analyzer/dsniff/ChangeLog
+++ b/net-analyzer/dsniff/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/dsniff
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/ChangeLog,v 1.39 2006/10/31 21:28:37 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/ChangeLog,v 1.40 2006/12/01 23:06:45 cedk Exp $
+
+ 01 Dec 2006; Cedric Krier <cedk@gentoo.org> +files/2.3-openssl.patch,
+ dsniff-2.3-r10.ebuild:
+ Fix bug #146573
31 Oct 2006; Markus Ullmann <jokey@gentoo.org> dsniff-2.3-r7.ebuild,
dsniff-2.3-r10.ebuild, dsniff-2.4_beta1-r3.ebuild:
diff --git a/net-analyzer/dsniff/dsniff-2.3-r10.ebuild b/net-analyzer/dsniff/dsniff-2.3-r10.ebuild
index 81575587cfc7..d867ca6e4071 100644
--- a/net-analyzer/dsniff/dsniff-2.3-r10.ebuild
+++ b/net-analyzer/dsniff/dsniff-2.3-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/dsniff-2.3-r10.ebuild,v 1.4 2006/10/31 21:28:37 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/dsniff-2.3-r10.ebuild,v 1.5 2006/12/01 23:06:45 cedk Exp $
inherit eutils flag-o-matic
@@ -51,6 +51,11 @@ src_unpack() {
# bug 125084
epatch ${FILESDIR}/${PN}-httppostfix.patch
+
+ # bug #146573
+ if has_version '>=dev-libs/openssl-0.9.8'; then
+ epatch "${FILESDIR}"/${PV}-openssl.patch
+ fi
}
src_compile() {
diff --git a/net-analyzer/dsniff/files/2.3-openssl.patch b/net-analyzer/dsniff/files/2.3-openssl.patch
new file mode 100644
index 000000000000..b7df13d8acd5
--- /dev/null
+++ b/net-analyzer/dsniff/files/2.3-openssl.patch
@@ -0,0 +1,12 @@
+diff -ru dsniff-2.3~/sshcrypto.c dsniff-2.3/sshcrypto.c
+--- dsniff-2.3~/sshcrypto.c 2006-12-01 23:44:43.000000000 +0100
++++ dsniff-2.3/sshcrypto.c 2006-12-01 23:46:52.000000000 +0100
+@@ -14,6 +14,8 @@
+
+ #include <sys/types.h>
+ #include <openssl/ssl.h>
++#include <openssl/blowfish.h>
++#include <openssl/des.h>
+
+ #include <err.h>
+ #include <stdio.h>