summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pylzma/ChangeLog11
-rw-r--r--dev-python/pylzma/pylzma-0.4.2.ebuild26
2 files changed, 35 insertions, 2 deletions
diff --git a/dev-python/pylzma/ChangeLog b/dev-python/pylzma/ChangeLog
index 25db5ff6d0e5..6acb482b54b2 100644
--- a/dev-python/pylzma/ChangeLog
+++ b/dev-python/pylzma/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pylzma
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylzma/ChangeLog,v 1.2 2009/04/23 21:39:09 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylzma/ChangeLog,v 1.3 2010/07/03 22:20:51 arfrever Exp $
+
+*pylzma-0.4.2 (03 Jul 2010)
+
+ 03 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -pylzma-0.3.0.ebuild, -files/pylzma-0.3.0-fbsd.patch,
+ +pylzma-0.4.2.ebuild:
+ Version bump. Set SUPPORT_PYTHON_ABIS.
23 Apr 2009; Patrick Lauer <patrick@gentoo.org> metadata.xml:
Fixing metadata.xml
diff --git a/dev-python/pylzma/pylzma-0.4.2.ebuild b/dev-python/pylzma/pylzma-0.4.2.ebuild
new file mode 100644
index 000000000000..27eb0ccea3c4
--- /dev/null
+++ b/dev-python/pylzma/pylzma-0.4.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylzma/pylzma-0.4.2.ebuild,v 1.1 2010/07/03 22:20:51 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils eutils
+
+DESCRIPTION="Python bindings for the LZMA compression library"
+HOMEPAGE="http://www.joachim-bauch.de/projects/python/pylzma/ http://pypi.python.org/pypi/pylzma"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="doc/usage.txt readme.txt"