summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/setproctitle/ChangeLog7
-rw-r--r--dev-python/setproctitle/setproctitle-1.1.6.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-python/setproctitle/ChangeLog b/dev-python/setproctitle/ChangeLog
index 494f02db4105..376f08367574 100644
--- a/dev-python/setproctitle/ChangeLog
+++ b/dev-python/setproctitle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/setproctitle
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/setproctitle/ChangeLog,v 1.12 2012/04/22 17:16:43 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setproctitle/ChangeLog,v 1.13 2012/05/08 10:31:57 djc Exp $
+
+*setproctitle-1.1.6 (08 May 2012)
+
+ 08 May 2012; Dirkjan Ochtman <djc@gentoo.org> +setproctitle-1.1.6.ebuild:
+ Version bump to 1.1.6 (thanks jbergstroem for test fixes).
22 Apr 2012; Raúl Porcel <armin76@gentoo.org> setproctitle-1.1.2.ebuild,
setproctitle-1.1.3.ebuild:
diff --git a/dev-python/setproctitle/setproctitle-1.1.6.ebuild b/dev-python/setproctitle/setproctitle-1.1.6.ebuild
new file mode 100644
index 000000000000..22eaa4b04d1b
--- /dev/null
+++ b/dev-python/setproctitle/setproctitle-1.1.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setproctitle/setproctitle-1.1.6.ebuild,v 1.1 2012/05/08 10:31:57 djc Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils toolchain-funcs
+
+DESCRIPTION="Allow customization of the process title."
+HOMEPAGE="http://code.google.com/p/py-setproctitle/ http://pypi.python.org/pypi/setproctitle"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+DOCS="HISTORY.rst README.rst"
+
+src_prepare() {
+ python_copy_sources
+
+ conversion() {
+ [[ "${PYTHON_ABI}" == 2.* ]] && return
+ 2to3-${PYTHON_ABI} -w --no-diffs tests > /dev/null
+ }
+ python_execute_function \
+ --action-message 'Applying patches for $(python_get_implementation) $(python_get_version)' \
+ --failure-message 'Applying patches for $(python_get_implementation) $(python_get_version) failed' \
+ -s conversion
+}
+
+distutils_src_test_pre_hook() {
+ local version=$(python_get_version -l --major)
+ ln -fs pyrun-${PYTHON_ABI} tests/pyrun${version}
+}
+
+src_test() {
+ build_pyrun() {
+ echo $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -I$(python_get_includedir) -o tests/pyrun-${PYTHON_ABI} tests/pyrun.c $(python_get_library -l)
+ $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -I$(python_get_includedir) -o tests/pyrun-${PYTHON_ABI} tests/pyrun.c $(python_get_library -l)
+ }
+ python_execute_function -q -s build_pyrun
+
+ distutils_src_test
+} \ No newline at end of file