summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-biology/bioruby/ChangeLog9
-rw-r--r--sci-biology/bioruby/bioruby-1.4.3.0001-r1.ebuild38
-rw-r--r--sci-biology/bioruby/bioruby-9999.ebuild6
-rw-r--r--sci-biology/bioruby/files/bioruby-1.4.3.0001-fix-tests.patch29
4 files changed, 79 insertions, 3 deletions
diff --git a/sci-biology/bioruby/ChangeLog b/sci-biology/bioruby/ChangeLog
index 432845c9118f..9642a5bcb3bb 100644
--- a/sci-biology/bioruby/ChangeLog
+++ b/sci-biology/bioruby/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-biology/bioruby
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioruby/ChangeLog,v 1.17 2013/10/24 14:31:54 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioruby/ChangeLog,v 1.18 2013/11/25 01:13:15 mrueg Exp $
+
+*bioruby-1.4.3.0001-r1 (25 Nov 2013)
+
+ 25 Nov 2013; Manuel Rüger <mrueg@gentoo.org> +bioruby-1.4.3.0001-r1.ebuild,
+ +files/bioruby-1.4.3.0001-fix-tests.patch, bioruby-9999.ebuild:
+ NMU: Add missing dependency on libxml and ruby20 support. Fix tests see bug
+ #489712
24 Oct 2013; Tony Vroon <chainsaw@gentoo.org> bioruby-1.4.3.0001.ebuild:
Marked stable on AMD64 based on arch testing by Elijah "Armageddon" El
diff --git a/sci-biology/bioruby/bioruby-1.4.3.0001-r1.ebuild b/sci-biology/bioruby/bioruby-1.4.3.0001-r1.ebuild
new file mode 100644
index 000000000000..ec5740e9004b
--- /dev/null
+++ b/sci-biology/bioruby/bioruby-1.4.3.0001-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioruby/bioruby-1.4.3.0001-r1.ebuild,v 1.1 2013/11/25 01:13:15 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 ruby20"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An integrated environment for bioinformatics using the Ruby language"
+LICENSE="Ruby"
+HOMEPAGE="http://www.bioruby.org/"
+SRC_URI="http://www.${PN}.org/archive/${P}.tar.gz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+ruby_add_rdepend "dev-ruby/libxml"
+
+PATCHES=( "${FILESDIR}"/${P}-fix-tests.patch )
+
+each_ruby_configure() {
+ ${RUBY} setup.rb config || die
+}
+
+each_ruby_compile() {
+ ${RUBY} setup.rb setup || die
+}
+
+each_ruby_install() {
+ ${RUBY} setup.rb install --prefix="${D}" || die
+}
+
+each_ruby_test() {
+ ${RUBY} -rubygems test/runner.rb || die
+}
diff --git a/sci-biology/bioruby/bioruby-9999.ebuild b/sci-biology/bioruby/bioruby-9999.ebuild
index 3e2293783c7d..82342ab74b25 100644
--- a/sci-biology/bioruby/bioruby-9999.ebuild
+++ b/sci-biology/bioruby/bioruby-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioruby/bioruby-9999.ebuild,v 1.4 2013/09/14 12:55:24 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioruby/bioruby-9999.ebuild,v 1.5 2013/11/25 01:13:15 mrueg Exp $
EAPI=5
-USE_RUBY="ruby18 ruby19"
+USE_RUBY="ruby18 ruby19 ruby20"
EGIT_REPO_URI="git://github.com/bioruby/bioruby.git
https://github.com/bioruby/bioruby.git"
@@ -18,6 +18,8 @@ SLOT="0"
IUSE=""
KEYWORDS=""
+ruby_add_rdepend "dev-ruby/libxml"
+
all_ruby_unpack() {
git-2_src_unpack
}
diff --git a/sci-biology/bioruby/files/bioruby-1.4.3.0001-fix-tests.patch b/sci-biology/bioruby/files/bioruby-1.4.3.0001-fix-tests.patch
new file mode 100644
index 000000000000..71c4ca27104a
--- /dev/null
+++ b/sci-biology/bioruby/files/bioruby-1.4.3.0001-fix-tests.patch
@@ -0,0 +1,29 @@
+From edda65b8fb32c2eee6b0652074981c31aa68b0eb Mon Sep 17 00:00:00 2001
+From: Naohisa Goto <ng@bioruby.org>
+Date: Fri, 23 Aug 2013 23:51:59 +0900
+Subject: [PATCH] Test bug fix: Read test file with binary mode to avoid
+ encoding error
+
+ * Test bug fix: Read test file with binary mode to avoid string encoding
+ error. Thanks to nieder (github.com/nieder) who reports the bug.
+ (https://github.com/bioruby/bioruby/issues/84)
+---
+ test/unit/bio/db/test_phyloxml.rb | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/test/unit/bio/db/test_phyloxml.rb b/test/unit/bio/db/test_phyloxml.rb
+index 0744c64..c24278d 100644
+--- a/test/unit/bio/db/test_phyloxml.rb
++++ b/test/unit/bio/db/test_phyloxml.rb
+@@ -100,7 +100,7 @@ def test_open_with_block
+ end
+
+ def test_new
+- str = File.read(TestPhyloXMLData.example_xml)
++ str = File.open(TestPhyloXMLData.example_xml, "rb") { |f| f.read }
+ assert_instance_of(Bio::PhyloXML::Parser,
+ phyloxml = Bio::PhyloXML::Parser.new(str))
+ common_test_next_tree(phyloxml)
+--
+1.8.4
+