summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/rpy/ChangeLog8
-rw-r--r--dev-python/rpy/files/rpy-0.99.2-version-detect.patch11
-rw-r--r--dev-python/rpy/files/rpy-1.0_rc3-lib-handling.patch16
-rw-r--r--dev-python/rpy/files/rpy-lapack.patch20
-rw-r--r--dev-python/rpy/rpy-0.99.2-r1.ebuild53
-rw-r--r--dev-python/rpy/rpy-1.0.1.ebuild20
-rw-r--r--dev-python/rpy/rpy-1.0_rc3.ebuild56
7 files changed, 24 insertions, 160 deletions
diff --git a/dev-python/rpy/ChangeLog b/dev-python/rpy/ChangeLog
index e6ea0135c65e..22cc6342dfb1 100644
--- a/dev-python/rpy/ChangeLog
+++ b/dev-python/rpy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/rpy
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rpy/ChangeLog,v 1.19 2008/01/17 16:50:15 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rpy/ChangeLog,v 1.20 2008/02/26 20:06:19 bicatali Exp $
+
+ 26 Feb 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ -files/rpy-0.99.2-version-detect.patch,
+ -files/rpy-1.0_rc3-lib-handling.patch, -files/rpy-lapack.patch,
+ -rpy-0.99.2-r1.ebuild, -rpy-1.0_rc3.ebuild, rpy-1.0.1.ebuild:
+ Re-fixes lapack dependencies when USE=-lapack is asked
*rpy-1.0.1 (17 Jan 2008)
diff --git a/dev-python/rpy/files/rpy-0.99.2-version-detect.patch b/dev-python/rpy/files/rpy-0.99.2-version-detect.patch
deleted file mode 100644
index af192267361d..000000000000
--- a/dev-python/rpy/files/rpy-0.99.2-version-detect.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- rpy_tools.py 2006-07-28 13:12:02.000000000 +0100
-+++ rpy_tools.py 2006-07-28 13:11:35.000000000 +0100
-@@ -97,7 +97,7 @@
- if stat or len(output)<=0:
- raise RuntimeError("Couldn't execute the R interpreter" +
- " `%s'.\n" % rexec )
-- version = re.search("R +([0-9]\.[0-9]\.[0-9])", output)
-+ version = re.search("R version ([0-9]\.[0-9]\.[0-9])", output)
- if not version:
- raise RuntimeError("Couldn't obtain version number from output\n"
- "of `R --version'.\n")
diff --git a/dev-python/rpy/files/rpy-1.0_rc3-lib-handling.patch b/dev-python/rpy/files/rpy-1.0_rc3-lib-handling.patch
deleted file mode 100644
index 2e105aea0a0c..000000000000
--- a/dev-python/rpy/files/rpy-1.0_rc3-lib-handling.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -ur rpy-1.0-RC3/setup.py rpy-1.0-RC3.patched/setup.py
---- rpy-1.0-RC3/setup.py 2007-02-20 00:30:04.000000000 +0100
-+++ rpy-1.0-RC3.patched/setup.py 2007-09-07 14:22:04.000000000 +0200
-@@ -142,10 +142,11 @@
- import numpy
- DEFINE.append(('WITH_NUMERIC', '3'))
- DEFINE.append(('PY_ARRAY_TYPES_PREFIX', 'PyArray_'))
-- include_dirs.append(numpy.get_numpy_include())
-+ include_dirs.append(numpy.get_include())
- except ImportError:
- # fall back to Numeric
- try:
-+ import Numeric
- DEFINE.append(('WITH_NUMERIC', '1'))
- except ImportError:
- UNDEF.append('WITH_NUMERIC')
diff --git a/dev-python/rpy/files/rpy-lapack.patch b/dev-python/rpy/files/rpy-lapack.patch
deleted file mode 100644
index 15d5dd09876f..000000000000
--- a/dev-python/rpy/files/rpy-lapack.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- setup.py.orig 2008-01-17 16:34:18.090303918 +0000
-+++ setup.py 2008-01-17 16:34:34.247143104 +0000
-@@ -133,7 +133,7 @@
- elif sys.platform=='osf1V5':
- include_dirs = [ os.path.join(RHOME.strip(), 'include'),
- 'src' ]
-- libraries=['R','Rlapack']
-+ libraries=['R','lapack']
- library_dirs = r_libs
- runtime_libs = r_libs
- extra_compile_args=["-shared"]
-@@ -141,7 +141,7 @@
- else: # unix-like systems, this is known to work for Linux and Solaris
- include_dirs = [ os.path.join(RHOME.strip(), 'include'),
- 'src', '/usr/share/R/include' ]
-- libraries=['R','Rlapack']
-+ libraries=['R','lapack']
- library_dirs = r_libs
- runtime_libs = r_libs
- extra_compile_args=["-shared"]
diff --git a/dev-python/rpy/rpy-0.99.2-r1.ebuild b/dev-python/rpy/rpy-0.99.2-r1.ebuild
deleted file mode 100644
index 33a57f9cfa1b..000000000000
--- a/dev-python/rpy/rpy-0.99.2-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rpy/rpy-0.99.2-r1.ebuild,v 1.1 2007/09/27 07:34:16 hawking Exp $
-
-inherit distutils eutils
-
-DESCRIPTION="RPy is a very simple, yet robust, Python interface to the R Programming Language."
-HOMEPAGE="http://rpy.sourceforge.net/"
-SRC_URI="mirror://sourceforge/rpy/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~x86"
-IUSE="examples lapack"
-
-DEPEND="virtual/python
- >=dev-lang/R-2.3
- dev-python/numeric
- lapack? ( virtual/lapack )"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- distutils_src_unpack
-
- # Fix lapack linking issue, bug 143396
- if use lapack; then
- sed -i \
- -e "s:Rlapack:lapack:" \
- setup.py || die "sed in setup.py failed"
- else
- sed -i \
- -e "s:'Rlapack'::" \
- setup.py || die "sed in setup.py failed"
- fi
-
- epatch "${FILESDIR}/${P}-version-detect.patch"
-}
-
-src_install() {
- distutils_src_install
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/*
- fi
-
- # add R libs to ld.so.conf
- doenvd "${FILESDIR}/90rpy"
-}
-
-pkg_postinst() {
- env-update
-}
diff --git a/dev-python/rpy/rpy-1.0.1.ebuild b/dev-python/rpy/rpy-1.0.1.ebuild
index 3de808490879..d5cb47925d3f 100644
--- a/dev-python/rpy/rpy-1.0.1.ebuild
+++ b/dev-python/rpy/rpy-1.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rpy/rpy-1.0.1.ebuild,v 1.1 2008/01/17 16:50:15 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rpy/rpy-1.0.1.ebuild,v 1.2 2008/02/26 20:06:19 bicatali Exp $
inherit distutils eutils
@@ -11,16 +11,30 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2 LGPL-2.1 MPL-1.1"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~x86"
-IUSE="doc examples"
+IUSE="doc examples lapack"
RDEPEND=">=dev-lang/R-2.6.1
+ lapack? ( virtual/lapack )
dev-python/numpy"
DEPEND="${RDEPEND}
doc? ( || ( virtual/tetex dev-texlive/texlive-texinfo ) )"
+pkg_setup() {
+ if use lapack && ! built_with_use dev-lang/R lapack; then
+ eerror "If you want ${PN} with lapack bindings,"
+ eerror "you also need dev-lang/R with lapack"
+ die "need dev-lang/R compiled with lapack"
+ fi
+}
+
src_unpack() {
distutils_src_unpack
- epatch "${FILESDIR}"/${PN}-lapack.patch
+ # Fix lapack linking issue, bug 143396
+ if use lapack; then
+ sed -i \
+ -e 's:Rlapack:lapack:g' \
+ setup.py || die "sed in setup.py failed"
+ fi
epatch "${FILESDIR}"/${PN}-1.0_rc3-version-detect.patch
epatch "${FILESDIR}"/${PN}-testfiles.patch
}
diff --git a/dev-python/rpy/rpy-1.0_rc3.ebuild b/dev-python/rpy/rpy-1.0_rc3.ebuild
deleted file mode 100644
index 807bf78458fa..000000000000
--- a/dev-python/rpy/rpy-1.0_rc3.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rpy/rpy-1.0_rc3.ebuild,v 1.1 2007/10/14 06:33:41 genstef Exp $
-
-inherit distutils eutils
-
-MY_P="${P/_rc/-RC}"
-DESCRIPTION="RPy is a very simple, yet robust, Python interface to the R Programming Language."
-HOMEPAGE="http://rpy.sourceforge.net/"
-SRC_URI="mirror://sourceforge/rpy/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~x86"
-IUSE="examples lapack"
-
-DEPEND=">=dev-lang/R-2.3
- dev-python/numpy
- lapack? ( virtual/lapack )"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- distutils_src_unpack
-
- # Fix lapack linking issue, bug 143396
- if use lapack; then
- sed -i \
- -e "s:Rlapack:lapack:" \
- setup.py || die "sed in setup.py failed"
- else
- sed -i \
- -e "s:'Rlapack'::" \
- setup.py || die "sed in setup.py failed"
- fi
-
- epatch "${FILESDIR}/${P}-version-detect.patch"
- epatch "${FILESDIR}/${P}-lib-handling.patch"
-}
-
-src_install() {
- distutils_src_install
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-
- # add R libs to ld.so.conf
- doenvd "${FILESDIR}/90rpy"
-}
-
-pkg_postinst() {
- elog "You'll have to run env-update in order to find the R libraries."
-}