summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/augeas')
-rw-r--r--app-admin/augeas/ChangeLog7
-rw-r--r--app-admin/augeas/augeas-0.5.0.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/app-admin/augeas/ChangeLog b/app-admin/augeas/ChangeLog
index 816622d9551d..3cc2125b0071 100644
--- a/app-admin/augeas/ChangeLog
+++ b/app-admin/augeas/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/augeas
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/augeas/ChangeLog,v 1.3 2009/03/24 23:19:14 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/augeas/ChangeLog,v 1.4 2009/03/29 16:59:34 matsuu Exp $
+
+*augeas-0.5.0 (29 Mar 2009)
+
+ 29 Mar 2009; MATSUU Takuto <matsuu@gentoo.org> +augeas-0.5.0.ebuild:
+ Version bumped. Fixed NaturalDocs related issue, bug #264063.
24 Mar 2009; Joseph Jezak <josejx@gentoo.org> augeas-0.4.1.ebuild:
Marked ~ppc for bug #263622.
diff --git a/app-admin/augeas/augeas-0.5.0.ebuild b/app-admin/augeas/augeas-0.5.0.ebuild
new file mode 100644
index 000000000000..7b565cf31516
--- /dev/null
+++ b/app-admin/augeas/augeas-0.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/augeas/augeas-0.5.0.ebuild,v 1.1 2009/03/29 16:59:34 matsuu Exp $
+
+DESCRIPTION="A library for changing configuration files"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="http://augeas.net/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc test"
+
+RDEPEND="sys-libs/readline"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/NaturalDocs-1.40 )
+ test? ( dev-lang/ruby )"
+
+src_compile() {
+ if [ -f /usr/share/NaturalDocs/Config/Languages.txt ] ; then
+ addwrite /usr/share/NaturalDocs/Config/Languages.txt
+ fi
+ if [ -f /usr/share/NaturalDocs/Config/Topics.txt ] ; then
+ addwrite /usr/share/NaturalDocs/Config/Topics.txt
+ fi
+
+ econf || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodoc AUTHORS ChangeLog README NEWS
+}