summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/sudo/sudo-1.6.8_p1-r1.ebuild')
-rw-r--r--app-admin/sudo/sudo-1.6.8_p1-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/sudo/sudo-1.6.8_p1-r1.ebuild b/app-admin/sudo/sudo-1.6.8_p1-r1.ebuild
new file mode 100644
index 000000000000..438aaa55d5d8
--- /dev/null
+++ b/app-admin/sudo/sudo-1.6.8_p1-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sudo/sudo-1.6.8_p1-r1.ebuild,v 1.1 2004/09/17 19:44:33 taviso Exp $
+
+inherit gnuconfig eutils
+
+#
+# TODO: Fix support for krb4 and krb5
+#
+
+DESCRIPTION="Allows certain users/groups to run commands as root"
+HOMEPAGE="http://www.sudo.ws/"
+SRC_URI="ftp://ftp.sudo.ws/pub/sudo/${P/_/}.tar.gz"
+
+LICENSE="Sudo"
+SLOT="0"
+KEYWORDS="-*"
+#KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~s390 ~ppc64"
+IUSE="pam skey"
+
+DEPEND="pam? ( >=sys-libs/pam-0.73-r1 )
+ skey? ( >=app-admin/skey-1.1.5-r1 )"
+
+S=${WORKDIR}/${P/_/}
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ gnuconfig_update
+
+ epatch ${FILESDIR}/${P}-suid_fix.patch
+ use skey && epatch ${FILESDIR}/${PN}-skeychallengeargs.diff
+}
+
+src_compile() {
+ econf \
+ --with-all-insults \
+ --disable-path-info \
+ --with-env-editor \
+ `use_with pam` \
+ `use_with skey` \
+ || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc BUGS CHANGES HISTORY PORTING README RUNSON TODO \
+ TROUBLESHOOTING UPGRADE sample.*
+ insinto /etc/pam.d
+ doins ${FILESDIR}/sudo
+}
+
+pkg_postinst() {
+ use skey && use pam && {
+ ewarn "sudo will not use skey authentication when compiled with"
+ ewarn "pam support. to allow users to authenticate with one time"
+ ewarn "passwords, you should unset the pam USE flag for sudo."
+ }
+}