summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/unrar/files/digest-unrar-2.501
-rw-r--r--app-arch/unrar/unrar-2.50.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-arch/unrar/files/digest-unrar-2.50 b/app-arch/unrar/files/digest-unrar-2.50
new file mode 100644
index 000000000000..ac1c7fbe2bd0
--- /dev/null
+++ b/app-arch/unrar/files/digest-unrar-2.50
@@ -0,0 +1 @@
+MD5 9b9b9acc4d681af5b7b85dd2d9132c14 unrar250.zip
diff --git a/app-arch/unrar/unrar-2.50.ebuild b/app-arch/unrar/unrar-2.50.ebuild
new file mode 100644
index 000000000000..c4ef0d381d18
--- /dev/null
+++ b/app-arch/unrar/unrar-2.50.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Joe Bormolini <lordjoe@gentoo.org>
+
+A=unrar250.zip
+S=${WORKDIR}/${P}
+DESCRIPTION="Uncompress rar files"
+SRC_URI="ftp://ftp.elf.stuba.sk/pub/pc/pack/${A}"
+HOMEPAGE="ftp://ftp.elf.stuba.sk/pub/pc/pack"
+
+DEPEND="virtual/glibc"
+RDEPEND="virtual/glibc"
+# Might be more depends... probably not, though
+
+src_compile() {
+# Many many warnings... but seems to work okay
+ cd src
+ mv Makefile Makefile.orig
+ sed -e "s:-O2:${CFLAGS}:" Makefile.orig > Makefile
+ try make
+}
+
+src_install() {
+ cd ${S}
+ dobin src/unrar
+ dodoc readme.txt license.txt
+}
+
+
+