summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/gnupg/files')
-rw-r--r--app-crypt/gnupg/files/gnupg-2.0.12-adns.patch21
-rw-r--r--app-crypt/gnupg/files/gnupg-2.0.9-gcc-4.3.patch11
2 files changed, 21 insertions, 11 deletions
diff --git a/app-crypt/gnupg/files/gnupg-2.0.12-adns.patch b/app-crypt/gnupg/files/gnupg-2.0.12-adns.patch
new file mode 100644
index 000000000000..7f62267e48ea
--- /dev/null
+++ b/app-crypt/gnupg/files/gnupg-2.0.12-adns.patch
@@ -0,0 +1,21 @@
+--- configure.ac
++++ configure.ac
+@@ -820,11 +820,13 @@
+ CPPFLAGS="${CPPFLAGS} -I$withval/include"
+ LDFLAGS="${LDFLAGS} -L$withval/lib"
+ fi])
+-AC_CHECK_HEADERS(adns.h,
+- AC_CHECK_LIB(adns, adns_init,
+- [have_adns=yes],
+- [CPPFLAGS=${_cppflags} LDFLAGS=${_ldflags}]),
+- [CPPFLAGS=${_cppflags} LDFLAGS=${_ldflags}])
++if test "$with_adns" != "no"; then
++ AC_CHECK_HEADERS(adns.h,
++ AC_CHECK_LIB(adns, adns_init,
++ [have_adns=yes],
++ [CPPFLAGS=${_cppflags} LDFLAGS=${_ldflags}]),
++ [CPPFLAGS=${_cppflags} LDFLAGS=${_ldflags}])
++fi
+ if test "$have_adns" = "yes"; then
+ ADNSLIBS="-ladns"
+ fi
diff --git a/app-crypt/gnupg/files/gnupg-2.0.9-gcc-4.3.patch b/app-crypt/gnupg/files/gnupg-2.0.9-gcc-4.3.patch
deleted file mode 100644
index 0cad7bc6d8de..000000000000
--- a/app-crypt/gnupg/files/gnupg-2.0.9-gcc-4.3.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- keyserver/gpgkeys_curl.c 2007-07-04 15:26:13.000000000 +0200
-+++ keyserver/gpgkeys_curl.c.new 2008-04-16 22:14:52.000000000 +0200
-@@ -300,7 +300,7 @@
- curl_easy_setopt(curl,CURLOPT_VERBOSE,1);
- }
-
-- curl_easy_setopt(curl,CURLOPT_SSL_VERIFYPEER,opt->flags.check_cert);
-+ curl_easy_setopt(curl,CURLOPT_SSL_VERIFYPEER, opt->flags.check_cert != 0);
- curl_easy_setopt(curl,CURLOPT_CAINFO,opt->ca_cert_file);
-
- if(proxy)