summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-dicts/gjiten/gjiten-2.2.ebuild')
-rw-r--r--app-dicts/gjiten/gjiten-2.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-dicts/gjiten/gjiten-2.2.ebuild b/app-dicts/gjiten/gjiten-2.2.ebuild
new file mode 100644
index 000000000000..c689460464e3
--- /dev/null
+++ b/app-dicts/gjiten/gjiten-2.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/gjiten/gjiten-2.2.ebuild,v 1.1 2004/06/16 13:00:14 jmglov Exp $
+
+DESCRIPTION="A Japanese dictionary program for Gnome"
+HOMEPAGE="http://gjiten.sourceforge.net/"
+SRC_URI="http://${PN}.sourceforge.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND=">=gnome-base/libgnome-2.2
+ >=gnome-base/libgnomeui-2.2
+ >=x11-libs/gtk+-2"
+RDEPEND="gnome-base/libgnome
+ x11-libs/gtk+"
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS Changelog INSTALL NEWS README THANKS TODO
+ dohtml index.html gjiten.xml legal.xml gjiten-doc.ja.html
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Dictionary files are necessary in order for"
+ einfo "Gjiten to function."
+ einfo
+ einfo "Download dictionary files from:"
+ einfo "http://ftp.cc.monash.edu.au/pub/nihongo/00INDEX.html#dic_fil"
+ einfo "You need kanjidic and edict at a minimum. Dictionary files"
+ einfo "must be converted to UTF-8 format - check the Gjiten help"
+ einfo "and README files for details."
+ einfo
+ einfo "A shell script is available from "
+ einfo "the Gjiten homepage(${HOMEPAGE}) to"
+ einfo "download and convert the dictionary files, but you need"
+ einfo "to put the files in /usr/share/gjiten after running the script."
+ einfo
+}