summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/elisp-manual/elisp-manual-23.3.0.ebuild')
-rw-r--r--app-doc/elisp-manual/elisp-manual-23.3.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-doc/elisp-manual/elisp-manual-23.3.0.ebuild b/app-doc/elisp-manual/elisp-manual-23.3.0.ebuild
new file mode 100644
index 000000000000..5ccf35e5b06e
--- /dev/null
+++ b/app-doc/elisp-manual/elisp-manual-23.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/elisp-manual/elisp-manual-23.3.0.ebuild,v 1.1 2009/09/05 23:40:01 ulm Exp $
+
+inherit eutils
+
+MY_P=${PN}-${PV/./-}
+DESCRIPTION="The GNU Emacs Lisp Reference Manual"
+HOMEPAGE="http://www.gnu.org/software/emacs/manual/"
+# Taken from doc/lispref/ of emacs-23.1
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+
+LICENSE="FDL-1.3"
+SLOT="23"
+KEYWORDS="~amd64 ~ppc ~s390 ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-direntry.patch"
+}
+
+src_compile() {
+ makeinfo elisp.texi || die "makeinfo failed"
+}
+
+src_install() {
+ doinfo elisp23.info* || die "doinfo failed"
+ dodoc ChangeLog README
+}