summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/gedit/gedit-2.16.0.ebuild')
-rw-r--r--app-editors/gedit/gedit-2.16.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-editors/gedit/gedit-2.16.0.ebuild b/app-editors/gedit/gedit-2.16.0.ebuild
new file mode 100644
index 000000000000..2eee009db9a6
--- /dev/null
+++ b/app-editors/gedit/gedit-2.16.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.16.0.ebuild,v 1.1 2006/09/07 03:54:04 dang Exp $
+
+inherit gnome2
+
+DESCRIPTION="A text editor for the GNOME desktop"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="spell python"
+
+RDEPEND=">=gnome-base/gconf-2
+ >=dev-libs/glib-2.12
+ >=x11-libs/gtk+-2.10
+ >=x11-libs/gtksourceview-1.8.0
+ >=gnome-base/libgnomeui-2.16
+ >=gnome-base/libglade-2.5.1
+ >=gnome-base/libgnomeprintui-2.12.1
+ >=gnome-base/gnome-vfs-2.16
+ >=gnome-base/orbit-2
+ >=gnome-base/libbonobo-2
+ spell? ( virtual/aspell-dict )
+ python? (
+ >=dev-python/pygtk-2.9.7
+ >=dev-python/gnome-python-desktop-2.15.90
+ )"
+# FIXME : spell autodetect only
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9
+ >=app-text/scrollkeeper-0.3.11
+ >=dev-util/intltool-0.35
+ >=app-text/gnome-doc-utils-0.3"
+
+DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README THANKS TODO"
+