summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/hteditor/hteditor-0.8.0_pre1.ebuild')
-rw-r--r--app-editors/hteditor/hteditor-0.8.0_pre1.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/app-editors/hteditor/hteditor-0.8.0_pre1.ebuild b/app-editors/hteditor/hteditor-0.8.0_pre1.ebuild
index 8e83efd9b2b9..fb6f07010b06 100644
--- a/app-editors/hteditor/hteditor-0.8.0_pre1.ebuild
+++ b/app-editors/hteditor/hteditor-0.8.0_pre1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/hteditor-0.8.0_pre1.ebuild,v 1.3 2004/06/27 22:13:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/hteditor-0.8.0_pre1.ebuild,v 1.4 2004/10/26 13:21:33 vapier Exp $
+
+inherit toolchain-funcs
DESCRIPTION="editor for executable files"
HOMEPAGE="http://hte.sourceforge.net/"
@@ -8,13 +10,12 @@ SRC_URI="mirror://sourceforge/hte/ht-${PV/_/}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc -alpha"
+KEYWORDS="~ppc ~x86"
IUSE=""
RDEPEND="virtual/libc
virtual/x11
sys-libs/ncurses"
-
DEPEND="${RDEPEND}
>=sys-devel/automake-1.4
sys-devel/autoconf
@@ -25,10 +26,10 @@ S="${WORKDIR}/ht-${PV/_/}"
src_compile() {
chmod +x configure
- local myconf="--prefix=/usr --sysconfdir=/etc"
- ./configure ${myconf} || die
- emake "CC=${CC}" CXX=${CXX} "CFLAGS=${CFLAGS}" \
- "CXXFLAGS=${CXXFLAGS}" "LDFLAGS=${LDFLAGS}"|| die
+ ./configure --prefix=/usr --sysconfdir=/etc || die
+ emake \
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}" || die
}
src_install() {