summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/jove/jove-4.16.0.64.ebuild')
-rw-r--r--app-editors/jove/jove-4.16.0.64.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-editors/jove/jove-4.16.0.64.ebuild b/app-editors/jove/jove-4.16.0.64.ebuild
new file mode 100644
index 000000000000..d6632c08c120
--- /dev/null
+++ b/app-editors/jove/jove-4.16.0.64.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jove/jove-4.16.0.64.ebuild,v 1.1 2005/03/11 13:34:19 seemant Exp $
+
+inherit eutils
+
+DESCRIPTION="Jonathan's Own Version of Emacs -- a light emacs-like editor without LISP bindings"
+HOMEPAGE="ftp://ftp.cs.toronto.edu/cs/ftp/pub/hugh/jove-dev/"
+SRC_URI="mirror://debian/pool/main/j/${PN}/${P/-/_}.orig.tar.gz
+ mirror://debian/pool/main/j/${PN}/${P/-/_}-1.diff.gz"
+RESTRICT="nomirror"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86 ~amd64"
+IUSE="X"
+
+RDEPEND="sys-libs/ncurses
+ X? ( x11-libs/xview )"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/${PN}${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${DISTDIR}/${PN}_${PV}-1.diff.gz
+
+ sed -i \
+ -e "s:^OPTFLAGS =.*:OPTFLAGS = ${CFLAGS}:" \
+ -e "s:-ltermcap:-lncurses:" \
+ Makefile
+}
+
+src_compile() {
+ emake || die
+
+ if use X ; then
+ emake XJOVEHOME=/usr makexjove || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+
+ if use X ; then
+ make DESTDIR=${D} XJOVEHOME=${D}/usr MANDIR=${D}/usr/share/man/man1 installxjove || die
+ fi
+
+ keepdir /var/lib/jove/preserve
+}