summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/vim-core')
-rw-r--r--app-editors/vim-core/ChangeLog7
-rw-r--r--app-editors/vim-core/vim-core-7.3.646.ebuild20
2 files changed, 26 insertions, 1 deletions
diff --git a/app-editors/vim-core/ChangeLog b/app-editors/vim-core/ChangeLog
index 772b92f4a3f4..ff309605d343 100644
--- a/app-editors/vim-core/ChangeLog
+++ b/app-editors/vim-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/vim-core
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/ChangeLog,v 1.403 2012/07/12 12:58:19 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/ChangeLog,v 1.404 2012/08/30 00:12:50 lack Exp $
+
+*vim-core-7.3.646 (30 Aug 2012)
+
+ 30 Aug 2012; Jim Ramsay <jim_ramsay@gentoo.org> +vim-core-7.3.646.ebuild:
+ Version bump: 7.3.646 is released
*vim-core-7.3.600 (12 Jul 2012)
diff --git a/app-editors/vim-core/vim-core-7.3.646.ebuild b/app-editors/vim-core/vim-core-7.3.646.ebuild
new file mode 100644
index 000000000000..a03c5c1800e9
--- /dev/null
+++ b/app-editors/vim-core/vim-core-7.3.646.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/vim-core-7.3.646.ebuild,v 1.1 2012/08/30 00:12:50 lack Exp $
+
+EAPI=3
+VIM_VERSION="7.3"
+inherit vim
+
+VIM_CORE_GENTOO_PATCHES="vim-core-${VIM_VERSION}-gentoo-patches-r1.tar.bz2"
+VIM_ORG_PATCHES="vim-patches-${PV}.patch.bz2"
+VIMRC_FILE_SUFFIX="-r4"
+
+SRC_URI="ftp://ftp.vim.org/pub/vim/unix/vim-${VIM_VERSION}.tar.bz2
+ http://dev.gentoo.org/~lack/vim/${VIM_CORE_GENTOO_PATCHES}
+ http://dev.gentoo.org/~lack/vim/${VIM_ORG_PATCHES}"
+
+S="${WORKDIR}/vim${VIM_VERSION/.}"
+DESCRIPTION="vim and gvim shared files"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""