summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/vim/vim-6.1-r17.ebuild')
-rw-r--r--app-editors/vim/vim-6.1-r17.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/app-editors/vim/vim-6.1-r17.ebuild b/app-editors/vim/vim-6.1-r17.ebuild
new file mode 100644
index 000000000000..0e1e6fc25825
--- /dev/null
+++ b/app-editors/vim/vim-6.1-r17.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-6.1-r17.ebuild,v 1.1 2002/11/21 01:39:00 zhen Exp $
+
+inherit vim
+
+DESCRIPTION="Vi IMproved!"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+DEPEND="app-editors/vim-core
+ sys-libs/libtermcap-compat
+ dev-util/cscope
+ >=sys-libs/ncurses-5.2-r2
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ perl? ( sys-devel/perl )
+ python? ( dev-lang/python )
+ ruby? ( >=dev-lang/ruby-1.6.4 )"
+# tcltk? ( dev-lang/tcl )"
+
+src_compile() {
+ local myconf
+ myconf="--without-x --with-features=big --enable-multibyte"
+ use nls && myconf="$myconf --enable-multibyte"
+ use nls || myconf="$myconf --disable-nls"
+ use perl && myconf="$myconf --enable-perlinterp"
+ use python && myconf="$myconf --enable-pythoninterp"
+ use ruby && myconf="$myconf --enable-rubyinterp"
+
+# tclinterp is BROKEN. See note above DEPEND=
+# use tcltk && myconf="$myconf --enable-tclinterp"
+
+# Added back gpm for temporary will remove if necessary, I think that I have
+# fixed most of gpm so it should be fine.
+ use gpm || myconf="$myconf --disable-gpm"
+
+ # This should fix a sandbox violation.
+ addwrite "${SSH_TTY}"
+
+ #
+ # Build a nogui version, this will install as /usr/bin/vim
+ #
+ ./configure \
+ --prefix=/usr --mandir=/usr/share/man --host=$CHOST \
+ --with-features=huge --with-cscope $myconf \
+ --enable-gui=no \
+ || die "vim configure failed"
+ # Parallel make does not work
+ make || die "vim make failed"
+}
+
+src_install() {
+ dobin src/vim
+ ln -s vim ${D}/usr/bin/vimdiff
+ # Default vimrc
+ insinto /usr/share/vim
+ doins ${FILESDIR}/vimrc
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "gvim has now a seperate ebuild, 'emerge gvim' will install gvim"
+}