summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/nxml-mode/nxml-mode-20041004-r1.ebuild')
-rw-r--r--app-emacs/nxml-mode/nxml-mode-20041004-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-emacs/nxml-mode/nxml-mode-20041004-r1.ebuild b/app-emacs/nxml-mode/nxml-mode-20041004-r1.ebuild
new file mode 100644
index 000000000000..fbe40d1a5674
--- /dev/null
+++ b/app-emacs/nxml-mode/nxml-mode-20041004-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/nxml-mode/nxml-mode-20041004-r1.ebuild,v 1.1 2007/08/15 07:37:56 ulm Exp $
+
+inherit elisp eutils
+
+DESCRIPTION="A major mode for GNU Emacs for editing XML documents."
+HOMEPAGE="http://www.thaiopensource.com/nxml-mode/
+http://www.emacswiki.org/cgi-bin/wiki/NxmlMode"
+SRC_URI="http://thaiopensource.com/download/${P}.tar.gz
+ mirror://gentoo/${PN}-20040910-xmlschema.patch.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+SITEFILE=80${PN}-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-info-gentoo.patch"
+ epatch "${WORKDIR}/${PN}-20040910-xmlschema.patch"
+ epatch "${FILESDIR}/xsd-regexp.el.2006-01-26.patch" # bug #188112
+}
+
+src_compile() {
+ emacs -batch -l rng-auto.el -f rng-byte-compile-load \
+ || die "byte compilation failed"
+ makeinfo --force nxml-mode.texi || die "makeinfo failed"
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ cp -r "${S}/schema" "${D}/${SITELISP}/${PN}"
+ cp -r "${S}/char-name" "${D}/${SITELISP}/${PN}"
+ doinfo nxml-mode.info
+ dodoc README VERSION TODO NEWS || die "dodoc failed"
+}