summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine/wine-20050310.ebuild')
-rw-r--r--app-emulation/wine/wine-20050310.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/app-emulation/wine/wine-20050310.ebuild b/app-emulation/wine/wine-20050310.ebuild
index 542ccabbc1d4..f30a9636abb8 100644
--- a/app-emulation/wine/wine-20050310.ebuild
+++ b/app-emulation/wine/wine-20050310.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050310.ebuild,v 1.1 2005/03/13 11:00:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050310.ebuild,v 1.2 2005/03/15 23:35:33 vapier Exp $
inherit eutils flag-o-matic
@@ -36,6 +36,16 @@ DEPEND="${RDEPEND}
doc? ( app-text/docbook-sgml-utils app-text/jadetex )
sys-devel/flex"
+pkg_setup() {
+ if use amd64 && ! has_m32; then
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "Make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit code"
+ fi
+}
+
src_unpack() {
unpack Wine-${PV}.tar.gz
cd "${S}"