summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/xen-tools/ChangeLog6
-rw-r--r--app-emulation/xen-tools/xen-tools-3.0.4_p1.ebuild6
-rw-r--r--app-emulation/xen-tools/xen-tools-3.1.0.ebuild6
3 files changed, 13 insertions, 5 deletions
diff --git a/app-emulation/xen-tools/ChangeLog b/app-emulation/xen-tools/ChangeLog
index 027434bc817a..d85373379aa1 100644
--- a/app-emulation/xen-tools/ChangeLog
+++ b/app-emulation/xen-tools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/xen-tools
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.26 2007/08/26 21:40:41 marineam Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.27 2007/08/27 17:20:23 marineam Exp $
+
+ 27 Aug 2007; Michael Marineau <marineam@gentoo.org>
+ xen-tools-3.0.4_p1.ebuild, xen-tools-3.1.0.ebuild:
+ Die if both x86 and amd64 are set in USE.
26 Aug 2007; Michael Marineau <marineam@gentoo.org>
+files/xen-tools-3.1.0-xen-detect-nopie-fix.patch, xen-tools-3.1.0.ebuild:
diff --git a/app-emulation/xen-tools/xen-tools-3.0.4_p1.ebuild b/app-emulation/xen-tools/xen-tools-3.0.4_p1.ebuild
index 68248c524a50..730ca00cf96e 100644
--- a/app-emulation/xen-tools/xen-tools-3.0.4_p1.ebuild
+++ b/app-emulation/xen-tools/xen-tools-3.0.4_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-3.0.4_p1.ebuild,v 1.4 2007/07/10 17:28:02 marineam Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-3.0.4_p1.ebuild,v 1.5 2007/08/27 17:20:23 marineam Exp $
inherit flag-o-matic distutils eutils multilib
@@ -55,7 +55,9 @@ pkg_setup() {
fi
if [[ -z ${XEN_TARGET_ARCH} ]] ; then
- if use x86 ; then
+ if use x86 && use amd64; then
+ die "Confusion! Both x86 and amd64 are set in your use flags!"
+ elif use x86; then
export XEN_TARGET_ARCH="x86_32"
elif use amd64 ; then
export XEN_TARGET_ARCH="x86_64"
diff --git a/app-emulation/xen-tools/xen-tools-3.1.0.ebuild b/app-emulation/xen-tools/xen-tools-3.1.0.ebuild
index d20d66f0b70b..f3ef7e08c34d 100644
--- a/app-emulation/xen-tools/xen-tools-3.1.0.ebuild
+++ b/app-emulation/xen-tools/xen-tools-3.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-3.1.0.ebuild,v 1.3 2007/08/26 21:40:41 marineam Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-3.1.0.ebuild,v 1.4 2007/08/27 17:20:23 marineam Exp $
inherit flag-o-matic distutils eutils multilib
@@ -61,7 +61,9 @@ pkg_setup() {
fi
if [[ -z ${XEN_TARGET_ARCH} ]] ; then
- if use x86 ; then
+ if use x86 && use amd64; then
+ die "Confusion! Both x86 and amd64 are set in your use flags!"
+ elif use x86; then
export XEN_TARGET_ARCH="x86_32"
elif use amd64 ; then
export XEN_TARGET_ARCH="x86_64"