summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/zsh/zsh-4.0.7.ebuild')
-rw-r--r--app-shells/zsh/zsh-4.0.7.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/app-shells/zsh/zsh-4.0.7.ebuild b/app-shells/zsh/zsh-4.0.7.ebuild
index 9f3bb362e9d8..b2fa455237a6 100644
--- a/app-shells/zsh/zsh-4.0.7.ebuild
+++ b/app-shells/zsh/zsh-4.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.0.7.ebuild,v 1.1 2003/07/23 17:48:19 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.0.7.ebuild,v 1.2 2003/07/23 20:21:36 usata Exp $
IUSE="maildir ncurses"
@@ -26,7 +26,7 @@ src_unpack() {
epatch ${MYPATCH}
epatch ${ZSHALL}
}
-
+
src_compile() {
local myconf
@@ -45,7 +45,7 @@ src_compile() {
--enable-fndir=/usr/share/zsh/${PV}/functions \
--enable-site-fndir=/usr/share/zsh/site-functions \
--enable-function-subdirs \
- ${myconf}
+ ${myconf} || die "configure failed"
# emake still b0rks
make || die "make failed"
#make check || die "make check failed"
@@ -68,3 +68,12 @@ src_install() {
docinto StartupFiles
dodoc StartupFiles/z*
}
+
+pkg_preinst() {
+ # Our zprofile file does the job of the old zshenv file
+ # Move the old version into a zprofile script so the normal
+ # etc-update process will handle any changes.
+ if [ -f /etc/zsh/zshenv -a ! -f /etc/zsh/zprofile ]; then
+ mv /etc/zsh/zshenv /etc/zsh/zprofile
+ fi
+}