summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash-completion/ChangeLog8
-rw-r--r--app-shells/bash-completion/bash-completion-20030327.ebuild45
-rw-r--r--app-shells/bash-completion/files/digest-bash-completion-200303271
3 files changed, 53 insertions, 1 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index 00b72b7d8909..d464718c5814 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/bash-completion
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.31 2003/03/13 18:34:20 doctomoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.32 2003/03/27 13:13:57 joker Exp $
+
+*bash-completion-20030327 (27 Mar 2003)
+
+ 27 Mar 2003; Christian Birchinger <joker@gentoo.org>
+ bash-completion-20030327.ebuild:
+ Version bump to 20030327 (on all archs)
13 Mar 2003; Olivier Reisch <doctomoe@gentoo.org> bash-completion-20021231.ebuild:
Marked ppc stable
diff --git a/app-shells/bash-completion/bash-completion-20030327.ebuild b/app-shells/bash-completion/bash-completion-20030327.ebuild
new file mode 100644
index 000000000000..34028568bd18
--- /dev/null
+++ b/app-shells/bash-completion/bash-completion-20030327.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20030327.ebuild,v 1.1 2003/03/27 13:13:57 joker Exp $
+
+S=${WORKDIR}/${PN/-/_}
+DESCRIPTION="Programmable Completion for bash (includes emerge and ebuild commands)."
+HOMEPAGE="http://www.caliban.org/bash/index.shtml#completion"
+SRC_URI="http://www.caliban.org/files/bash/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc alpha mips hppa arm"
+
+DEPEND="sys-apps/tar
+ sys-apps/bzip2"
+
+RDEPEND=">=app-shells/bash-2.05a"
+
+src_install() {
+ insinto /etc
+ doins bash_completion
+
+ insinto /etc/bash_completion.d
+
+ doins contrib/dict
+ doins contrib/harbour
+ doins contrib/isql
+ doins contrib/larch
+ doins contrib/lilypond
+ doins contrib/p4
+ doins contrib/ri
+
+ doins ${FILESDIR}/gentoo.completion
+
+ insinto /etc/profile.d
+ doins ${FILESDIR}/bash-completion
+
+ dodoc COPYING Changelog README
+}
+
+pkg_postinst() {
+ einfo "Add the following line to your ~/.bashrc to"
+ einfo "activate completion support in your bash:"
+ einfo "[ -f /etc/profile.d/bash-completion ] && source /etc/profile.d/bash-completion"
+}
diff --git a/app-shells/bash-completion/files/digest-bash-completion-20030327 b/app-shells/bash-completion/files/digest-bash-completion-20030327
new file mode 100644
index 000000000000..9c230fe748b8
--- /dev/null
+++ b/app-shells/bash-completion/files/digest-bash-completion-20030327
@@ -0,0 +1 @@
+MD5 0cde596cefa39821ff14b542f21bdc45 bash-completion-20030327.tar.bz2 62836