summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/pdsh/ChangeLog10
-rw-r--r--app-shells/pdsh/pdsh-2.17.ebuild43
2 files changed, 51 insertions, 2 deletions
diff --git a/app-shells/pdsh/ChangeLog b/app-shells/pdsh/ChangeLog
index 58b0d90426c2..1e0b5d495031 100644
--- a/app-shells/pdsh/ChangeLog
+++ b/app-shells/pdsh/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/pdsh
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/pdsh/ChangeLog,v 1.12 2008/08/03 15:20:56 ulm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/pdsh/ChangeLog,v 1.13 2009/02/05 00:24:58 jsbronder Exp $
+
+*pdsh-2.17 (05 Feb 2009)
+
+ 05 Feb 2009; Justin Bronder <jsbronder@gentoo.org> +pdsh-2.17.ebuild:
+ Bump app-shells/pdsh-2.17 (#255239). Also adding RESTRICT=test as, so far
+ as I can tell, the test suite never worked.
03 Aug 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/app-shells/pdsh/pdsh-2.17.ebuild b/app-shells/pdsh/pdsh-2.17.ebuild
new file mode 100644
index 000000000000..372058f61c6e
--- /dev/null
+++ b/app-shells/pdsh/pdsh-2.17.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/pdsh/pdsh-2.17.ebuild,v 1.1 2009/02/05 00:24:58 jsbronder Exp $
+
+inherit eutils
+
+DESCRIPTION="A high-performance, parallel remote shell utility."
+HOMEPAGE="https://computing.llnl.gov/linux/pdsh.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crypt readline rsh"
+RDEPEND="crypt? ( net-misc/openssh )
+ rsh? ( net-misc/netkit-rsh )
+ readline? ( sys-libs/readline )"
+DEPEND="${RDEPEND}"
+
+# Feel free to debug the test suite.
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-2.14-gcc-4.3-unistd.h.patch
+ epatch "${FILESDIR}"/${PN}-2.14-glibc-2.8-ARG_MAX.patch
+}
+
+src_compile() {
+ econf \
+ --with-machines \
+ $(use_with crypt ssh) \
+ $(use_with rsh) \
+ $(use_with readline) \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}