summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/convertlit/convertlit-1.8.ebuild')
-rw-r--r--app-text/convertlit/convertlit-1.8.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-text/convertlit/convertlit-1.8.ebuild b/app-text/convertlit/convertlit-1.8.ebuild
new file mode 100644
index 000000000000..3ba8c21cff40
--- /dev/null
+++ b/app-text/convertlit/convertlit-1.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/convertlit/convertlit-1.8.ebuild,v 1.1 2004/09/02 04:26:40 usata Exp $
+
+MY_P="clit${PV//./}"
+
+DESCRIPTION="CLit converts MS ebook .lit files to .opf (xml+html+png+jpg)"
+HOMEPAGE="http://www.convertlit.com/"
+SRC_URI="http://www.convertlit.com/${MY_P}src.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+DEPEND="dev-libs/libtommath
+ >=sys-apps/sed-4"
+RDEPEND="" # link libtommath statically
+IUSE=""
+
+S=${WORKDIR}
+
+src_compile() {
+ cd ${S}/lib
+ sed -i -e "/^CFLAGS/s/-O3 -Wall/${CFLAGS}/" Makefile \
+ || die "sed lib/Makefile failed."
+ emake || die "make lib failed"
+ cd ${S}/${MY_P}
+ sed -i -e "/^CFLAGS/s:-Wall -O2:${CFLAGS}:" \
+ -e "s:../libtommath-0.30:/usr/lib:g" Makefile \
+ || die "sed ${MY_P}/Makefile failed."
+ emake || die "make ${MY_P} failed"
+}
+
+src_install() {
+ dobin ${S}/${MY_P}/clit
+ dodoc ${S}/README
+}