summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/sloccount/sloccount-2.26-r1.ebuild')
-rw-r--r--app-text/sloccount/sloccount-2.26-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-text/sloccount/sloccount-2.26-r1.ebuild b/app-text/sloccount/sloccount-2.26-r1.ebuild
new file mode 100644
index 000000000000..6362cd89b0e1
--- /dev/null
+++ b/app-text/sloccount/sloccount-2.26-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/sloccount/sloccount-2.26-r1.ebuild,v 1.1 2005/02/27 04:49:38 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Tools for counting Source Lines of Code (SLOC) for a large number of languages"
+HOMEPAGE="http://www.dwheeler.com/sloccount/"
+SRC_URI="http://www.dwheeler.com/sloccount/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64 ~sparc"
+IUSE=""
+RDEPEND="dev-lang/perl
+ >=sys-apps/sed-4
+ app-shells/bash"
+DEPEND="${RDEPEND}
+ sys-devel/gcc"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-libexec.patch
+ epatch ${FILESDIR}/${P}-coreutils-tail-n-fix.patch
+
+ sed -i \
+ -e "/^CC/ { s/$/ ${CFLAGS}/g }" \
+ -e "/^DOC_DIR/ { s/-\$(RPM_VERSION)//g }" \
+ -e "/^MYDOCS/ { s/[^ =]\+\.html//g }" \
+ makefile || die "sed makefile failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall PREFIX="${D}/usr" || die
+ prepalldocs
+ dohtml *html
+}