summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/qpdf/ChangeLog7
-rw-r--r--app-text/qpdf/qpdf-5.0.1.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/app-text/qpdf/ChangeLog b/app-text/qpdf/ChangeLog
index b4e0af42472e..70e1a9651a24 100644
--- a/app-text/qpdf/ChangeLog
+++ b/app-text/qpdf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/qpdf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/qpdf/ChangeLog,v 1.36 2013/08/06 12:34:30 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/qpdf/ChangeLog,v 1.37 2013/10/19 12:24:57 radhermit Exp $
+
+*qpdf-5.0.1 (19 Oct 2013)
+
+ 19 Oct 2013; Tim Harder <radhermit@gentoo.org> +qpdf-5.0.1.ebuild:
+ Version bump (bug #488564).
06 Aug 2013; Agostino Sarubbo <ago@gentoo.org> qpdf-4.1.0.ebuild:
Stable for s390, wrt bug #442926
diff --git a/app-text/qpdf/qpdf-5.0.1.ebuild b/app-text/qpdf/qpdf-5.0.1.ebuild
new file mode 100644
index 000000000000..edd1397973a7
--- /dev/null
+++ b/app-text/qpdf/qpdf-5.0.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/qpdf/qpdf-5.0.1.ebuild,v 1.1 2013/10/19 12:24:57 radhermit Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="A command-line program that does structural, content-preserving transformations on PDF files"
+HOMEPAGE="http://qpdf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qpdf/${P}.tar.gz"
+
+LICENSE="Artistic-2"
+SLOT="0/13" # subslot = libqpdf soname version
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~m68k-mint"
+IUSE="doc examples static-libs test"
+
+RDEPEND="dev-libs/libpcre
+ sys-libs/zlib
+ >=dev-lang/perl-5.8"
+DEPEND="${RDEPEND}
+ test? (
+ sys-apps/diffutils
+ media-libs/tiff
+ app-text/ghostscript-gpl
+ )"
+
+DOCS=( ChangeLog README TODO )
+
+src_prepare() {
+ # manually install docs
+ sed -i "/docdir/d" make/libtool.mk || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable test test-compare-images)
+}
+
+src_install() {
+ default
+
+ if use doc ; then
+ dodoc doc/qpdf-manual.pdf
+ dohtml doc/*
+ fi
+
+ if use examples ; then
+ dobin examples/build/.libs/*
+ fi
+
+ prune_libtool_files
+}