summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/gocr/ChangeLog9
-rw-r--r--app-text/gocr/files/gocr-0.46-makefile.patch21
-rw-r--r--app-text/gocr/gocr-0.46.ebuild49
3 files changed, 78 insertions, 1 deletions
diff --git a/app-text/gocr/ChangeLog b/app-text/gocr/ChangeLog
index 1d2bb924d226..e195021e6461 100644
--- a/app-text/gocr/ChangeLog
+++ b/app-text/gocr/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/gocr
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/ChangeLog,v 1.55 2008/04/06 18:55:37 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/ChangeLog,v 1.56 2008/10/26 13:43:25 aballier Exp $
+
+*gocr-0.46 (26 Oct 2008)
+
+ 26 Oct 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/gocr-0.46-makefile.patch, +gocr-0.46.ebuild:
+ version bump, thanks to Ed Davison for the report and Daniel Pielmeier for
+ the updated patch. Bug #243250
06 Apr 2008; Tobias Klausmann <klausman@gentoo.org> gocr-0.45.ebuild:
Stable on alpha, bug #189461
diff --git a/app-text/gocr/files/gocr-0.46-makefile.patch b/app-text/gocr/files/gocr-0.46-makefile.patch
new file mode 100644
index 000000000000..5d14e8398a67
--- /dev/null
+++ b/app-text/gocr/files/gocr-0.46-makefile.patch
@@ -0,0 +1,21 @@
+--- gocr-0.46/src/Makefile.in 2008-02-05 22:20:44.000000000 +0100
++++ gocr-0.46/src/Makefile.in.new 2008-10-22 20:55:41.000000000 +0200
+@@ -48,7 +48,8 @@
+ CPPFLAGS=@CPPFLAGS@
+ # to see the config.h
+ CFLAGS=@CFLAGS@ $(CPPFLAGS) -I../include $(DEFS)
+-LDFLAGS=@LDFLAGS@ @LIBS@ -L.
++LDFLAGS=@LDFLAGS@
++LIBADD=@LIBS@
+ DESTDIR=@prefix@
+
+ .c.o: gocr.h pgm2asc.h ../include/config.h
+@@ -67,7 +68,7 @@
+ $(PROGRAM): $(LIBOBJS) gocr.o
+ # make it conform to ld --as-needed
+ #$(CC) -o $@ gocr.o ./lib$(PGMASCLIB).a $(LDFLAGS)
+- $(CC) -o $@ gocr.o $(LIBOBJS) $(LDFLAGS)
++ $(CC) $(LDFLAGS) gocr.o $(LIBOBJS) $(LIBADD) -o $@
+ if test -r $(PROGRAM); then cp $@ ../bin; fi
+ #$(LIBPGMASCLIB): $(LIBOBJS)
+ # -rm -f $@
diff --git a/app-text/gocr/gocr-0.46.ebuild b/app-text/gocr/gocr-0.46.ebuild
new file mode 100644
index 000000000000..3a5e7f961a40
--- /dev/null
+++ b/app-text/gocr/gocr-0.46.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/gocr-0.46.ebuild,v 1.1 2008/10/26 13:43:25 aballier Exp $
+
+inherit eutils
+
+DESCRIPTION="An OCR (Optical Character Recognition) reader"
+HOMEPAGE="http://jocr.sourceforge.net"
+SRC_URI="mirror://sourceforge/jocr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc tk"
+
+DEPEND=">=media-libs/netpbm-9.12
+ doc? ( >=media-gfx/transfig-3.2 virtual/ghostscript )
+ tk? ( dev-lang/tk )"
+
+DOCS="AUTHORS BUGS CREDITS HISTORY RE* TODO"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ local mymakes="src man"
+
+ use doc && mymakes="${mymakes} doc examples"
+
+ econf || die "econf failed"
+ emake ${mymakes} || die "make ${mymakes} failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="/usr" exec_prefix="/usr" install || die "make install failed"
+ # remove the tk frontend if tk is not selected
+ use tk || rm "${D}"/usr/bin/gocr.tcl
+ # and install the documentation and examples
+ if use doc ; then
+ DOCS="${DOCS} doc/gocr.html doc/examples.txt doc/unicode.txt"
+ insinto /usr/share/doc/${P}/examples
+ doins "${S}"/examples/*.{fig,tex,pcx}
+ fi
+ # and then install all the docs
+ dodoc ${DOCS}
+}