summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/gmock/gmock-1.5.0.ebuild')
-rw-r--r--dev-cpp/gmock/gmock-1.5.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-cpp/gmock/gmock-1.5.0.ebuild b/dev-cpp/gmock/gmock-1.5.0.ebuild
index 350b594c7ac6..d02b8873aed4 100644
--- a/dev-cpp/gmock/gmock-1.5.0.ebuild
+++ b/dev-cpp/gmock/gmock-1.5.0.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gmock/gmock-1.5.0.ebuild,v 1.2 2011/11/11 20:12:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gmock/gmock-1.5.0.ebuild,v 1.3 2011/11/11 20:35:50 vapier Exp $
EAPI="4"
+inherit libtool
+
DESCRIPTION="Google's C++ mocking framework"
HOMEPAGE="http://code.google.com/p/googlemock/"
SRC_URI="http://googlemock.googlecode.com/files/${P}.tar.bz2"
@@ -22,6 +24,10 @@ src_unpack() {
rm -r "${S}"/gtest/Makefile* || die
}
+src_prepare() {
+ elibtoolize
+}
+
src_configure() {
econf $(use_enable static-libs static)
}