summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/libxmlpp/ChangeLog24
-rw-r--r--dev-cpp/libxmlpp/Manifest5
-rw-r--r--dev-cpp/libxmlpp/libxmlpp-0.21.0.ebuild24
-rw-r--r--dev-cpp/libxmlpp/libxmlpp-0.24.0.ebuild24
4 files changed, 77 insertions, 0 deletions
diff --git a/dev-cpp/libxmlpp/ChangeLog b/dev-cpp/libxmlpp/ChangeLog
new file mode 100644
index 000000000000..5d6d99ce9b14
--- /dev/null
+++ b/dev-cpp/libxmlpp/ChangeLog
@@ -0,0 +1,24 @@
+# ChangeLog for dev-cpp/libxmlpp
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/ChangeLog,v 1.1 2003/06/19 00:41:50 liquidx Exp $
+
+*libxmlpp-0.24.0 (19 Jun 2003)
+
+ 19 Jun 2003; Alastair Tse <liquidx@gentoo.org> libxmlpp-0.24.0.ebuild:
+ Moved package from dev-libs/libxml++ to dev-cpp/libxmlpp and version
+ bump
+
+ 06 Jun 2003; Jason Wever <weeve@gentoo.org> libxml++-0.21.0.ebuild:
+ Added ~sparc to keywords.
+
+*libxml++-0.21.0 (02 Mar 2003)
+
+ 03 Mar 2003; Graham Forest <vladimir@gentoo.org> libxml++-0.21.0.ebuild:
+ Added empty IUSE
+
+ 03 Mar 2003; Graham Forest <vladimir@gentoo.org> libxml++-0.21.0.ebuild:
+ Adressed mirror and symlink issues as suggested by Max Kalika
+ <max@lsit.ucsp.edu>
+
+ 02 Mar 2003; Graham Forest <vladimir@gentoo.org libxml++-0.21.0.ebuild:
+ Initial import. Ebuild submitted by Andre Lemos <tux@tuxslare.org>.
diff --git a/dev-cpp/libxmlpp/Manifest b/dev-cpp/libxmlpp/Manifest
new file mode 100644
index 000000000000..8c80e3e7d315
--- /dev/null
+++ b/dev-cpp/libxmlpp/Manifest
@@ -0,0 +1,5 @@
+MD5 57f527debff02c1b5b94925e8d352497 ChangeLog 931
+MD5 76f64aefe5fc57b111ae3458cabe2bb7 libxmlpp-0.24.0.ebuild 764
+MD5 2d5343978f556a2171c53fab49806edc libxmlpp-0.21.0.ebuild 764
+MD5 e0003dbc9c05d0efc0a4db25e5d8e281 files/digest-libxmlpp-0.24.0 67
+MD5 4cccf711f0f3740e58ab60b7ba4bad86 files/digest-libxmlpp-0.21.0 67
diff --git a/dev-cpp/libxmlpp/libxmlpp-0.21.0.ebuild b/dev-cpp/libxmlpp/libxmlpp-0.21.0.ebuild
new file mode 100644
index 000000000000..157dac6e3f72
--- /dev/null
+++ b/dev-cpp/libxmlpp/libxmlpp-0.21.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/libxmlpp-0.21.0.ebuild,v 1.1 2003/06/19 00:41:50 liquidx Exp $
+
+MY_P=${P/pp/++}
+DESCRIPTION="C++ wrapper for the libxml XML parser library"
+HOMEPAGE="http://libxmlplusplus.sourceforge.net/"
+SRC_URI="mirror://sourceforge/libxmlplusplus/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE=""
+
+DEPEND=">=dev-libs/libxml2-2.5.1"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ einstall install || die "Install failed"
+# dosym /usr/lib/libxml++-0.1.a /usr/lib/libxml++.a
+# dosym /usr/lib/libxml++-0.1.so /usr/lib/libxml++.so
+ dodoc AUTHORS COPYING ChangeLog NEWS README*
+}
diff --git a/dev-cpp/libxmlpp/libxmlpp-0.24.0.ebuild b/dev-cpp/libxmlpp/libxmlpp-0.24.0.ebuild
new file mode 100644
index 000000000000..2b39a24e13aa
--- /dev/null
+++ b/dev-cpp/libxmlpp/libxmlpp-0.24.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/libxmlpp-0.24.0.ebuild,v 1.1 2003/06/19 00:41:50 liquidx Exp $
+
+MY_P=${P/pp/++}
+DESCRIPTION="C++ wrapper for the libxml XML parser library"
+HOMEPAGE="http://libxmlplusplus.sourceforge.net/"
+SRC_URI="mirror://sourceforge/libxmlplusplus/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE=""
+
+DEPEND=">=dev-libs/libxml2-2.5.1"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ einstall install || die "Install failed"
+# dosym /usr/lib/libxml++-0.1.a /usr/lib/libxml++.a
+# dosym /usr/lib/libxml++-0.1.so /usr/lib/libxml++.so
+ dodoc AUTHORS COPYING ChangeLog NEWS README*
+}