summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/sqlite')
-rw-r--r--dev-db/sqlite/ChangeLog8
-rw-r--r--dev-db/sqlite/files/digest-sqlite-3.3.123
-rw-r--r--dev-db/sqlite/files/digest-sqlite-3.4.23
-rw-r--r--dev-db/sqlite/sqlite-3.3.12.ebuild102
-rw-r--r--dev-db/sqlite/sqlite-3.4.2.ebuild94
5 files changed, 6 insertions, 204 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index 149a9e474353..d5f1a62dbf8c 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/sqlite
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.170 2007/12/17 21:33:29 betelgeuse Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.171 2008/01/08 00:21:48 betelgeuse Exp $
+
+ 08 Jan 2008; Petteri Räty <betelgeuse@gentoo.org> -sqlite-3.3.12.ebuild,
+ -sqlite-3.4.2.ebuild:
+ Remove obsolete versions.
*sqlite-3.5.4 (17 Dec 2007)
diff --git a/dev-db/sqlite/files/digest-sqlite-3.3.12 b/dev-db/sqlite/files/digest-sqlite-3.3.12
deleted file mode 100644
index adc1561bebd5..000000000000
--- a/dev-db/sqlite/files/digest-sqlite-3.3.12
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 ae251cc7a4b54b80941d400ed5af01b7 sqlite-3.3.12.tar.gz 2021696
-RMD160 98154b3e8663b6c7ec11a7094a51781ee8384317 sqlite-3.3.12.tar.gz 2021696
-SHA256 e005781cb0356f65200c05979c04fea533b9a7d873e0060672a4d384468b7186 sqlite-3.3.12.tar.gz 2021696
diff --git a/dev-db/sqlite/files/digest-sqlite-3.4.2 b/dev-db/sqlite/files/digest-sqlite-3.4.2
deleted file mode 100644
index 96e8e4b9f9f4..000000000000
--- a/dev-db/sqlite/files/digest-sqlite-3.4.2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 2feec9b429f9298c9f288420c8b449f8 sqlite-3.4.2.tar.gz 2377646
-RMD160 5833523fedced44b18cc2955b6356be00713412b sqlite-3.4.2.tar.gz 2377646
-SHA256 0ad86c4b26cd687122b158bf848f0a07d7cd644033d15c4f43b6d643bd74cd81 sqlite-3.4.2.tar.gz 2377646
diff --git a/dev-db/sqlite/sqlite-3.3.12.ebuild b/dev-db/sqlite/sqlite-3.3.12.ebuild
deleted file mode 100644
index 2b677425f112..000000000000
--- a/dev-db/sqlite/sqlite-3.3.12.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.12.ebuild,v 1.14 2007/06/24 21:21:22 vapier Exp $
-
-inherit eutils alternatives libtool
-
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-
-DESCRIPTION="SQLite: an SQL Database Engine in a C Library."
-HOMEPAGE="http://www.sqlite.org/"
-SRC_URI="http://www.sqlite.org/${P}.tar.gz"
-LICENSE="as-is"
-SLOT="3"
-IUSE="debug doc nothreadsafe tcl"
-
-DEPEND="doc? ( dev-lang/tcl )
- tcl? ( dev-lang/tcl )"
-
-RDEPEND="tcl? ( dev-lang/tcl )"
-
-SOURCE="/usr/bin/lemon"
-ALTERNATIVES="${SOURCE}-3 ${SOURCE}-0"
-
-RESTRICT="!tcl? ( test )"
-
-src_unpack() {
- # test
- if has test ${FEATURES}; then
- if ! has userpriv ${FEATURES}; then
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
- if ! use tcl; then
- ewarn "You must enable the tcl use flag if you want to run the test"
- ewarn "suite."
- eerror "Testsuite will not be run."
- fi
- fi
-
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/sqlite-3.3.3-tcl-fix.patch
- #epatch "${FILESDIR}"/sqlite-3-test-fix-3.3.4.patch
-
- #epatch "${FILESDIR}"/sandbox-fix1.patch
- epatch "${FILESDIR}"/sandbox-fix2.patch
-
- # Fix broken tests that are not portable to 64bit arches
- epatch "${FILESDIR}"/sqlite-64bit-test-fix.patch
- epatch "${FILESDIR}"/sqlite-64bit-test-fix2.patch
-
- # Respect LDFLAGS wrt bug #156299
- sed -i -e 's/^LTLINK = .*/& $(LDFLAGS)/' Makefile.in
-
- elibtoolize
- epunt_cxx
-}
-
-src_compile() {
- local myconf="--enable-incore-db --enable-tempdb-in-ram --enable-cross-thread-connections"
-
- econf ${myconf} \
- $(use_enable debug) \
- $(use_enable !nothreadsafe threadsafe) \
- $(use_enable tcl) \
- || die "econf failed"
-
- emake all || die "emake all failed"
-
- if use doc ; then
- emake doc || die "emake doc failed"
- fi
-}
-
-src_test() {
- if use tcl ; then
- if has userpriv ${FEATURES} ; then
- cd "${S}"
- if use debug ; then
- emake fulltest || die "some test failed"
- else
- emake test || die "some test failed"
- fi
- fi
- fi
-}
-
-src_install () {
- make \
- DESTDIR="${D}" \
- TCLLIBDIR="/usr/$(get_libdir)" \
- install \
- || die "make install failed"
-
- newbin lemon lemon-${SLOT}
-
- dodoc README VERSION
- doman sqlite3.1
-
- use doc && dohtml doc/* art/*.gif
-}
diff --git a/dev-db/sqlite/sqlite-3.4.2.ebuild b/dev-db/sqlite/sqlite-3.4.2.ebuild
deleted file mode 100644
index eda769a449d2..000000000000
--- a/dev-db/sqlite/sqlite-3.4.2.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.4.2.ebuild,v 1.1 2007/10/12 02:05:16 robbat2 Exp $
-
-inherit flag-o-matic eutils alternatives libtool
-
-DESCRIPTION="an SQL Database Engine in a C Library"
-HOMEPAGE="http://www.sqlite.org/"
-SRC_URI="http://www.sqlite.org/${P}.tar.gz"
-
-LICENSE="as-is"
-SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="debug doc nothreadsafe soundex tcl"
-RESTRICT="!tcl? ( test )"
-
-DEPEND="doc? ( dev-lang/tcl )
- tcl? ( dev-lang/tcl )"
-RDEPEND="tcl? ( dev-lang/tcl )"
-
-SOURCE="/usr/bin/lemon"
-ALTERNATIVES="${SOURCE}-3 ${SOURCE}-0"
-
-src_unpack() {
- # test
- if has test ${FEATURES}; then
- if ! has userpriv ${FEATURES}; then
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
- if ! use tcl; then
- ewarn "You must enable the tcl use flag if you want to run the test"
- ewarn "suite."
- eerror "Testsuite will not be run."
- fi
- fi
-
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/sandbox-fix2.patch
-
- # Respect LDFLAGS wrt bug #156299
- sed -i -e 's/^LTLINK = .*/& $(LDFLAGS)/' Makefile.in
-
- elibtoolize
- epunt_cxx
-}
-
-src_compile() {
- # not available via configure and requested in bug #143794
- use soundex && append-flags -DSQLITE_SOUNDEX=1
-
- econf ${myconf} \
- $(use_enable debug) \
- $(use_enable !nothreadsafe threadsafe) \
- $(use_enable !nothreadsafe cross-thread-connections) \
- $(use_enable tcl) \
- || die "econf failed"
-
- emake all || die "emake all failed"
-
- if use doc ; then
- emake doc || die "emake doc failed"
- fi
-}
-
-src_test() {
- if use tcl ; then
- if has userpriv ${FEATURES} ; then
- cd "${S}"
- if use debug ; then
- emake fulltest || die "some test failed"
- else
- emake test || die "some test failed"
- fi
- fi
- fi
-}
-
-src_install () {
- make \
- DESTDIR="${D}" \
- TCLLIBDIR="/usr/$(get_libdir)" \
- install \
- || die "make install failed"
-
- newbin lemon lemon-${SLOT} || die
-
- dodoc README VERSION || die
- doman sqlite3.1 || die
-
- use doc && dohtml doc/* art/*.gif
-}