summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/podsleuth/podsleuth-0.6.4.ebuild')
-rw-r--r--dev-dotnet/podsleuth/podsleuth-0.6.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-dotnet/podsleuth/podsleuth-0.6.4.ebuild b/dev-dotnet/podsleuth/podsleuth-0.6.4.ebuild
new file mode 100644
index 000000000000..e9a8c6f836df
--- /dev/null
+++ b/dev-dotnet/podsleuth/podsleuth-0.6.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/podsleuth/podsleuth-0.6.4.ebuild,v 1.1 2009/01/25 11:30:46 loki_val Exp $
+
+EAPI=2
+
+inherit mono
+
+DESCRIPTION="a tool to discover detailed model information about an Apple (TM) iPod (TM)."
+HOMEPAGE="http://banshee-project.org/PodSleuth"
+SRC_URI="http://banshee-project.org/files/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/mono-2.0
+ dev-dotnet/dbus-glib-sharp
+ >=sys-apps/hal-0.5.6
+ sys-apps/sg3_utils"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf --with-hal-callouts-dir=/usr/libexec
+}
+
+src_compile() {
+ emake -j1 || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README
+}