summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/gluezilla/ChangeLog8
-rw-r--r--dev-dotnet/gluezilla/files/gluezilla-2.6-fix-xulrunner-detection.patch25
-rw-r--r--dev-dotnet/gluezilla/files/gluezilla-2.6-xulrunner2.patch200
-rw-r--r--dev-dotnet/gluezilla/gluezilla-2.6-r1.ebuild4
-rw-r--r--dev-dotnet/gluezilla/gluezilla-2.6.ebuild26
-rw-r--r--dev-dotnet/gluezilla/gluezilla-9999.ebuild21
6 files changed, 209 insertions, 75 deletions
diff --git a/dev-dotnet/gluezilla/ChangeLog b/dev-dotnet/gluezilla/ChangeLog
index 686b1d706b16..d7868c9b6548 100644
--- a/dev-dotnet/gluezilla/ChangeLog
+++ b/dev-dotnet/gluezilla/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-dotnet/gluezilla
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gluezilla/ChangeLog,v 1.23 2011/03/21 20:22:21 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gluezilla/ChangeLog,v 1.24 2011/03/27 17:00:10 pacho Exp $
+
+ 27 Mar 2011; Pacho Ramos <pacho@gentoo.org> -gluezilla-2.6.ebuild,
+ gluezilla-2.6-r1.ebuild, -files/gluezilla-2.6-fix-xulrunner-detection.patch,
+ +files/gluezilla-2.6-xulrunner2.patch, -gluezilla-9999.ebuild:
+ Fix compilation against xulrunner-2.0 (bug #360791 by Rafał Mużyło),
+ remove old.
21 Mar 2011; Brent Baude <ranger@gentoo.org> gluezilla-2.6-r1.ebuild:
Marking gluezilla-2.6-r1 ppc stable for bug 359651
diff --git a/dev-dotnet/gluezilla/files/gluezilla-2.6-fix-xulrunner-detection.patch b/dev-dotnet/gluezilla/files/gluezilla-2.6-fix-xulrunner-detection.patch
deleted file mode 100644
index dacf32e60526..000000000000
--- a/dev-dotnet/gluezilla/files/gluezilla-2.6-fix-xulrunner-detection.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 42f469358dbc6143e05f5b8ebb96e316d662a786 Mon Sep 17 00:00:00 2001
-From: Priit Laes <plaes@plaes.org>
-Date: Sun, 21 Feb 2010 15:45:38 +0200
-Subject: [PATCH] Fix xulrunner detection.
-
----
- configure.ac | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index aa694b1..b122c5d 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -88,7 +88,7 @@ if test "x${local}" == xno ; then
- if test "x${oldxul}" != xyes ; then
-
- AC_MSG_CHECKING(Mozilla XPCOM > 1.8)
-- mozilla_xpcom_pcs="libxul-embedding-unstable"
-+ mozilla_xpcom_pcs="libxul-embedding-unstable libxul-embedding"
- for pc in $mozilla_xpcom_pcs; do
- if $PKG_CONFIG --exists $pc; then
- AC_MSG_RESULT($pc)
---
-1.7.0
-
diff --git a/dev-dotnet/gluezilla/files/gluezilla-2.6-xulrunner2.patch b/dev-dotnet/gluezilla/files/gluezilla-2.6-xulrunner2.patch
new file mode 100644
index 000000000000..77afed22934b
--- /dev/null
+++ b/dev-dotnet/gluezilla/files/gluezilla-2.6-xulrunner2.patch
@@ -0,0 +1,200 @@
+diff -ur gluezilla-2.6.orig/configure.ac gluezilla-2.6/configure.ac
+--- gluezilla-2.6.orig/configure.ac 2011-03-27 18:51:37.000000000 +0200
++++ gluezilla-2.6/configure.ac 2011-03-27 18:52:45.000000000 +0200
+@@ -87,16 +87,23 @@
+
+ if test "x${oldxul}" != xyes ; then
+
+- AC_MSG_CHECKING(Mozilla XPCOM > 1.8)
+- mozilla_xpcom_pcs="libxul-embedding-unstable"
+- for pc in $mozilla_xpcom_pcs; do
+- if $PKG_CONFIG --exists $pc; then
+- AC_MSG_RESULT($pc)
+- mozilla_xpcom=$pc
+- XUL_VERSION=3
+- break;
+- fi
+- done
++ if test -z $mozilla_xpcom; then
++ AC_MSG_CHECKING(Mozilla XPCOM > 1.8)
++ mozilla_xpcom_pcs="libxul-embedding libxul-embedding-unstable"
++ for pc in $mozilla_xpcom_pcs; do
++ if $PKG_CONFIG --exists $pc; then
++ mozilla_xpcom=$pc
++ XUL_VERSION=3
++ version="$(pkg-config --modversion $pc)"
++ minor=`echo "$version" | sed -e 's,\([[0-9]]*\)\..*,\1,'`
++ if test $minor -ge 2; then
++ XUL_VERSION=4
++ fi
++ AC_MSG_RESULT(Found $version)
++ break;
++ fi
++ done
++ fi
+ fi
+
+ if test -z $mozilla_xpcom; then
+@@ -121,10 +128,13 @@
+ XPCOM_PKGS="$mozilla_xpcom"
+ fi
+
+-AM_CONDITIONAL([OLDXUL], [test x$XUL_VERSION = x2])
+-
+ AC_SUBST(XUL_VERSION)
+
++AM_CONDITIONAL([XUL_4], [test x$XUL_VERSION = x4])
++AM_CONDITIONAL([XUL_3], [test x$XUL_VERSION = x3])
++AM_CONDITIONAL([XUL_2], [test x$XUL_VERSION = x2])
++
++
+ AC_ARG_ENABLE([optimize],
+ AC_HELP_STRING([--enable-optimize], [Enable optimizations (-O2)]),
+ [
+Sólo en gluezilla-2.6: configure.ac.orig
+Sólo en gluezilla-2.6: configure.ac.rej
+diff -ur gluezilla-2.6.orig/src/BrowserWindow.cpp gluezilla-2.6/src/BrowserWindow.cpp
+--- gluezilla-2.6.orig/src/BrowserWindow.cpp 2011-03-27 18:51:37.000000000 +0200
++++ gluezilla-2.6/src/BrowserWindow.cpp 2011-03-27 18:51:46.000000000 +0200
+@@ -28,23 +28,6 @@
+ NS_GENERIC_FACTORY_CONSTRUCTOR(SecurityWarningDialogs)
+ NS_GENERIC_FACTORY_CONSTRUCTOR(PromptService)
+
+-static const nsModuleComponentInfo components[] = {
+- {
+- SECURITYWARNINGSDIALOGS_CLASSNAME,
+- SECURITYWARNINGSDIALOGS_CID,
+- NS_SECURITYWARNINGDIALOGS_CONTRACTID,
+- SecurityWarningDialogsConstructor
+- },
+- {
+- PROMPTSERVICE_CLASSNAME,
+- PROMPTSERVICE_CID,
+- NS_PROMPTSERVICE_CONTRACTID,
+- PromptServiceConstructor
+- }
+-
+-};
+-
+-
+ BrowserWindow::BrowserWindow (void)
+ {
+ owner = nsnull;
+@@ -162,17 +145,17 @@
+ nsCOMPtr<nsIFactory> componentFactory;
+ rv = NS_NewSecurityWarningServiceFactory(getter_AddRefs(componentFactory));
+ if (NS_SUCCEEDED(rv)) {
+- compReg->RegisterFactory(components[0].mCID,
+- components[0].mDescription,
+- components[0].mContractID,
++ compReg->RegisterFactory(kSECURITYWARNINGSDIALOGS_CID,
++ SECURITYWARNINGSDIALOGS_CLASSNAME,
++ NS_SECURITYWARNINGDIALOGS_CONTRACTID,
+ componentFactory);
+ }
+
+ rv = NS_NewPromptServiceFactory(getter_AddRefs(componentFactory), this);
+ if (NS_SUCCEEDED(rv)) {
+- compReg->RegisterFactory(components[1].mCID,
+- components[1].mDescription,
+- components[1].mContractID,
++ compReg->RegisterFactory(kPROMPTSERVICE_CID,
++ PROMPTSERVICE_CLASSNAME,
++ NS_PROMPTSERVICE_CONTRACTID,
+ componentFactory);
+ }
+
+diff -ur gluezilla-2.6.orig/src/Makefile.am gluezilla-2.6/src/Makefile.am
+--- gluezilla-2.6.orig/src/Makefile.am 2011-03-27 18:51:37.000000000 +0200
++++ gluezilla-2.6/src/Makefile.am 2011-03-27 18:51:46.000000000 +0200
+@@ -26,7 +26,7 @@
+ gluezilla.h \
+ FastDelegate.h
+
+-if OLDXUL
++if XUL_2
+ libgluezilla_la_SOURCES += \
+ gluezilla_nsIScriptContext.h \
+ gluezilla_nsIScriptGlobalObject.h
+diff -ur gluezilla-2.6.orig/src/PromptService.h gluezilla-2.6/src/PromptService.h
+--- gluezilla-2.6.orig/src/PromptService.h 2011-03-27 18:51:37.000000000 +0200
++++ gluezilla-2.6/src/PromptService.h 2011-03-27 18:51:46.000000000 +0200
+@@ -20,8 +20,9 @@
+ // {77686174-2061-6d20-6920-746F20646F20}
+ #define PROMPTSERVICE_CID \
+ { 0x77686174, 0x2061, 0x6d20, { 0x69, 0x20, 0x74, 0x6F, 0x20, 0x64, 0x6F, 0x20 } }
+-
+-
++
++static NS_DEFINE_CID(kPROMPTSERVICE_CID, PROMPTSERVICE_CID);
++
+ class PromptService : public nsIPromptService
+ {
+ NS_DECL_ISUPPORTS
+diff -ur gluezilla-2.6.orig/src/SecurityWarningsDialogs.h gluezilla-2.6/src/SecurityWarningsDialogs.h
+--- gluezilla-2.6.orig/src/SecurityWarningsDialogs.h 2011-03-27 18:51:37.000000000 +0200
++++ gluezilla-2.6/src/SecurityWarningsDialogs.h 2011-03-27 18:51:46.000000000 +0200
+@@ -21,8 +21,9 @@
+ // {696E7465-7265-7374-696E-67206C696665}
+ #define SECURITYWARNINGSDIALOGS_CID \
+ { 0x696E7465, 0x7265, 0x7374, { 0x69, 0x6E, 0x67, 0x20, 0x6C, 0x69, 0x66, 0x65 } }
+-
+-
++
++static NS_DEFINE_CID(kSECURITYWARNINGSDIALOGS_CID, SECURITYWARNINGSDIALOGS_CID);
++
+ class SecurityWarningDialogs : public nsISecurityWarningDialogs
+ {
+ public:
+diff -ur gluezilla-2.6.orig/src/interfaces.h gluezilla-2.6/src/interfaces.h
+--- gluezilla-2.6.orig/src/interfaces.h 2011-03-27 18:51:37.000000000 +0200
++++ gluezilla-2.6/src/interfaces.h 2011-03-27 18:51:46.000000000 +0200
+@@ -4,7 +4,18 @@
+ #define TO_STRING(x) #x
+
+ //Gecko Embedding API
++#if XUL_VERSION < 4
+ #include <nsEmbedAPI.h>
++#else
++#include <nscore.h>
++#include <nsXPCOM.h>
++#include <nsILocalFile.h>
++#include <nsIDirectoryService.h>
++#define NS_GRE_COMPONENT_DIR "GreComsD"
++#define NS_XPCOM_COMPONENT_DIR "ComsD"
++#define NS_XPCOM_COMPONENT_REGISTRY_FILE "ComRegF"
++#define NS_XPCOM_XPTI_REGISTRY_FILE "XptiRegF"
++#endif
+
+ //XPCOM API
+ #include <nsCOMPtr.h>
+@@ -78,8 +89,12 @@
+ #include <nsIPromptService.h>
+ #include <nsISecurityWarningDialogs.h>
+ #include <nsIComponentRegistrar.h>
++#if XUL_VERSION < 4
+ #include <nsIGenericFactory.h>
+-
++#else
++#include <mozilla/ModuleUtils.h>
++struct nsModuleComponentInfo;
++#endif
+ // preferences
+ #include <nsIPrefBranch.h>
+ #include <nsIPrefService.h>
+@@ -131,12 +146,15 @@
+ typedef type (NS_FROZENCALL * name##Type) params; \
+ extern name##Type name NS_HIDDEN;
+
++#if XUL_VERSION < 4
+ XRE_API(nsresult,
+ XRE_InitEmbedding, (nsILocalFile *aLibXULDirectory,
+ nsILocalFile *aAppDirectory,
+ nsIDirectoryServiceProvider *aAppDirProvider,
+ nsStaticModuleInfo const *aStaticComponents,
+ PRUint32 aStaticComponentCount))
++#endif
++
+
+ XRE_API(void, XRE_TermEmbedding, ())
+
diff --git a/dev-dotnet/gluezilla/gluezilla-2.6-r1.ebuild b/dev-dotnet/gluezilla/gluezilla-2.6-r1.ebuild
index 4f30717173f9..bb6a619a4d86 100644
--- a/dev-dotnet/gluezilla/gluezilla-2.6-r1.ebuild
+++ b/dev-dotnet/gluezilla/gluezilla-2.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gluezilla/gluezilla-2.6-r1.ebuild,v 1.5 2011/03/21 20:22:21 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gluezilla/gluezilla-2.6-r1.ebuild,v 1.6 2011/03/27 17:00:10 pacho Exp $
EAPI=2
@@ -21,6 +21,6 @@ RDEPEND="net-libs/xulrunner:1.9
DEPEND="${RDEPEND}"
src_prepare() {
- epatch "${FILESDIR}/${P}-fix-xulrunner-detection.patch" || die "Failed to patch"
+ epatch "${FILESDIR}/${P}-xulrunner2.patch"
eautoreconf
}
diff --git a/dev-dotnet/gluezilla/gluezilla-2.6.ebuild b/dev-dotnet/gluezilla/gluezilla-2.6.ebuild
deleted file mode 100644
index b398ec493a11..000000000000
--- a/dev-dotnet/gluezilla/gluezilla-2.6.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gluezilla/gluezilla-2.6.ebuild,v 1.5 2010/10/19 21:20:40 loki_val Exp $
-
-EAPI=2
-
-inherit go-mono mono autotools
-
-DESCRIPTION="A simple library to embed Gecko (xulrunner) in the Mono Winforms WebControl"
-HOMEPAGE="http://mono-project.com/Gluezilla"
-
-LICENSE="LGPL-2 MPL-1.1"
-KEYWORDS="amd64 ppc x86"
-SLOT="0"
-IUSE=""
-
-RDEPEND="net-libs/xulrunner:1.9
- x11-libs/gtk+:2
- >=dev-lang/mono-${PV}
- "
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-fix-xulrunner-detection.patch" || die "Failed to patch"
- eautoreconf
-}
diff --git a/dev-dotnet/gluezilla/gluezilla-9999.ebuild b/dev-dotnet/gluezilla/gluezilla-9999.ebuild
deleted file mode 100644
index f18b5f871767..000000000000
--- a/dev-dotnet/gluezilla/gluezilla-9999.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gluezilla/gluezilla-9999.ebuild,v 1.3 2010/10/19 21:20:40 loki_val Exp $
-
-EAPI=2
-
-inherit go-mono mono
-
-DESCRIPTION="A simple library to embed Gecko (xulrunner) in the Mono Winforms WebControl"
-HOMEPAGE="http://mono-project.com/Gluezilla"
-
-LICENSE="LGPL-2 MPL-1.1"
-KEYWORDS=""
-SLOT="0"
-IUSE=""
-
-RDEPEND="net-libs/xulrunner:1.9
- x11-libs/gtk+:2
- dev-lang/mono
- "
-DEPEND="${RDEPEND}"