summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/guichan/guichan-0.8.1.ebuild')
-rw-r--r--dev-games/guichan/guichan-0.8.1.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/dev-games/guichan/guichan-0.8.1.ebuild b/dev-games/guichan/guichan-0.8.1.ebuild
index 2b16d7ad3996..568ea471f977 100644
--- a/dev-games/guichan/guichan-0.8.1.ebuild
+++ b/dev-games/guichan/guichan-0.8.1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/guichan-0.8.1.ebuild,v 1.2 2009/01/28 11:30:23 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/guichan-0.8.1.ebuild,v 1.3 2009/01/28 13:59:31 mr_bones_ Exp $
+EAPI=2
inherit eutils autotools
DESCRIPTION="a portable C++ GUI library designed for games using Allegro, SDL and/or OpenGL"
@@ -20,22 +21,18 @@ DEPEND="allegro? ( media-libs/allegro )
media-libs/sdl-image
)"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-as-needed.patch
eautoreconf
}
-src_compile() {
+src_configure() {
econf \
--disable-dependency-tracking \
$(use_enable allegro) \
$(use_enable opengl) \
$(use_enable sdl) \
- $(use_enable sdl sdlimage) \
- || die
- emake || die "emake failed"
+ $(use_enable sdl sdlimage)
}
src_install() {