summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hdbc-sqlite')
-rw-r--r--dev-haskell/hdbc-sqlite/ChangeLog6
-rw-r--r--dev-haskell/hdbc-sqlite/files/HDBC-sqlite3-2.3.3.0-ghc-7.6.patch52
-rw-r--r--dev-haskell/hdbc-sqlite/hdbc-sqlite-2.3.3.0.ebuild3
3 files changed, 59 insertions, 2 deletions
diff --git a/dev-haskell/hdbc-sqlite/ChangeLog b/dev-haskell/hdbc-sqlite/ChangeLog
index aaca0a5985f3..51bf94ba846a 100644
--- a/dev-haskell/hdbc-sqlite/ChangeLog
+++ b/dev-haskell/hdbc-sqlite/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-haskell/hdbc-sqlite
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-sqlite/ChangeLog,v 1.16 2012/12/07 10:35:19 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-sqlite/ChangeLog,v 1.17 2012/12/24 15:37:59 slyfox Exp $
+
+ 24 Dec 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/HDBC-sqlite3-2.3.3.0-ghc-7.6.patch, hdbc-sqlite-2.3.3.0.ebuild:
+ Fix against ghc-7.6.
07 Dec 2012; Sergei Trofimovich <slyfox@gentoo.org>
hdbc-sqlite-2.3.0.0.ebuild, hdbc-sqlite-2.3.3.0.ebuild:
diff --git a/dev-haskell/hdbc-sqlite/files/HDBC-sqlite3-2.3.3.0-ghc-7.6.patch b/dev-haskell/hdbc-sqlite/files/HDBC-sqlite3-2.3.3.0-ghc-7.6.patch
new file mode 100644
index 000000000000..c0c024218117
--- /dev/null
+++ b/dev-haskell/hdbc-sqlite/files/HDBC-sqlite3-2.3.3.0-ghc-7.6.patch
@@ -0,0 +1,52 @@
+--- HDBC-sqlite3-2.3.3.0-orig/testsrc/TestSbasics.hs 2011-08-10 07:08:57.000000000 +1000
++++ HDBC-sqlite3-2.3.3.0/testsrc/TestSbasics.hs 2012-10-13 11:28:21.094200366 +1100
+@@ -1,9 +1,13 @@
++{-# LANGUAGE CPP, ScopedTypeVariables #-}
+ module TestSbasics(tests) where
+ import Test.HUnit
+ import Database.HDBC
+ import TestUtils
+ import System.IO
+-import Control.Exception hiding (catch)
++#if !MIN_VERSION_base(4,6,0)
++import Prelude hiding (catch)
++#endif
++import Control.Exception
+
+ openClosedb = sqlTestCase $
+ do dbh <- connectDB
+@@ -140,7 +144,7 @@
+ -- Let's try a rollback.
+ catch (withTransaction dbh (\_ -> do sExecuteMany sth rows
+ fail "Foo"))
+- (\_ -> return ())
++ (\(_::IOException) -> return ())
+ sExecute qrysth []
+ sFetchAllRows qrysth >>= (assertEqual "rollback" [[Just "0"]])
+
+--- HDBC-sqlite3-2.3.3.0-orig/testsrc/Testbasics.hs 2011-08-10 07:08:57.000000000 +1000
++++ HDBC-sqlite3-2.3.3.0/testsrc/Testbasics.hs 2012-10-13 11:27:20.025541058 +1100
+@@ -1,9 +1,13 @@
++{-# LANGUAGE CPP, ScopedTypeVariables #-}
+ module Testbasics(tests) where
+ import Test.HUnit
+ import Database.HDBC
+ import TestUtils
+ import System.IO
+-import Control.Exception hiding (catch)
++#if !MIN_VERSION_base(4,6,0)
++import Prelude hiding (catch)
++#endif
++import Control.Exception
+
+ openClosedb = sqlTestCase $
+ do dbh <- connectDB
+@@ -140,7 +144,7 @@
+ -- Let's try a rollback.
+ catch (withTransaction dbh (\_ -> do executeMany sth rows
+ fail "Foo"))
+- (\_ -> return ())
++ (\(_::IOException) -> return ())
+ execute qrysth []
+ fetchAllRows qrysth >>= (assertEqual "rollback" [[SqlString "0"]])
+
diff --git a/dev-haskell/hdbc-sqlite/hdbc-sqlite-2.3.3.0.ebuild b/dev-haskell/hdbc-sqlite/hdbc-sqlite-2.3.3.0.ebuild
index c7ce84e75626..9eb26ffd300b 100644
--- a/dev-haskell/hdbc-sqlite/hdbc-sqlite-2.3.3.0.ebuild
+++ b/dev-haskell/hdbc-sqlite/hdbc-sqlite-2.3.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-sqlite/hdbc-sqlite-2.3.3.0.ebuild,v 1.3 2012/12/07 10:35:19 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-sqlite/hdbc-sqlite-2.3.3.0.ebuild,v 1.4 2012/12/24 15:37:59 slyfox Exp $
EAPI=4
@@ -38,6 +38,7 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
src_prepare() {
+ epatch "${FILESDIR}/${MY_PN}-2.3.3.0-ghc-7.6.patch"
cp "${FILESDIR}/TestTime.hs" "${S}/testsrc"
}