summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/osgi-core-api/osgi-core-api-5.0.0.ebuild')
-rw-r--r--dev-java/osgi-core-api/osgi-core-api-5.0.0.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/dev-java/osgi-core-api/osgi-core-api-5.0.0.ebuild b/dev-java/osgi-core-api/osgi-core-api-5.0.0.ebuild
index 0ad3af3fd757..7c63b9377c7e 100644
--- a/dev-java/osgi-core-api/osgi-core-api-5.0.0.ebuild
+++ b/dev-java/osgi-core-api/osgi-core-api-5.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/osgi-core-api/osgi-core-api-5.0.0.ebuild,v 1.3 2013/03/25 20:47:26 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/osgi-core-api/osgi-core-api-5.0.0.ebuild,v 1.4 2013/07/16 12:06:16 tomwij Exp $
EAPI=4
@@ -12,11 +12,13 @@ DESCRIPTION="OSGi Service Platform Core API (Companion Code)"
HOMEPAGE="http://www.osgi.org/Specifications/HomePage"
SRC_URI="http://www.osgi.org/download/r5/osgi.core-${PV}.jar"
-LICENSE="Apache-2.0"
+LICENSE="Apache-2.0 OSGi-Specification-2.0"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
+RESTRICT="bindist fetch"
+
RDEPEND="
>=virtual/jre-1.5"
DEPEND="
@@ -25,6 +27,14 @@ DEPEND="
JAVA_SRC_DIR="OSGI-OPT/src"
+pkg_nofetch() {
+ einfo "Please download osgi.core-${PV}.jar from"
+ einfo " http://www.osgi.org/Download/Release5"
+ einfo "which you can find listed as"
+ einfo " OSGi Core Release 5 Companion Code"
+ einfo "after accepting the license."
+}
+
java_prepare() {
rm -r org || die
}