summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/DirectFB/DirectFB-1.6.3-r1.ebuild')
-rw-r--r--dev-libs/DirectFB/DirectFB-1.6.3-r1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-libs/DirectFB/DirectFB-1.6.3-r1.ebuild b/dev-libs/DirectFB/DirectFB-1.6.3-r1.ebuild
index 4b9bd1608ca0..b8839734aa76 100644
--- a/dev-libs/DirectFB/DirectFB-1.6.3-r1.ebuild
+++ b/dev-libs/DirectFB/DirectFB-1.6.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-1.6.3-r1.ebuild,v 1.3 2014/07/31 06:02:26 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-1.6.3-r1.ebuild,v 1.4 2015/01/28 19:30:18 mgorny Exp $
EAPI=5
inherit autotools eutils toolchain-funcs
@@ -32,7 +32,7 @@ SRC_URI="http://directfb.org/downloads/Core/${PN}-${PV:0:3}/${P}.tar.gz
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 -mips ~ppc ~ppc64 ~sh -sparc ~x86"
-IUSE="bmp debug +dynload doc fbcon gif gles2 imlib2 input_hub jpeg jpeg2k mmx mng mpeg2 multicore opengl png pnm sdl sse static-libs svg truetype v4l vdpau X zlib ${IUV} ${IUD}"
+IUSE="bmp debug +dynload doc fbcon gif gles2 imlib2 input_hub jpeg jpeg2k cpu_flags_x86_mmx mng mpeg2 multicore opengl png pnm sdl cpu_flags_x86_sse static-libs svg truetype v4l vdpau X zlib ${IUV} ${IUD}"
REQUIRED_USE="gles2? ( opengl )"
# gstreamer useflag broken
@@ -107,8 +107,8 @@ src_configure() {
$(use_enable static-libs static) \
$(use_enable X x11) \
$(use_enable fbcon fbdev) \
- $(use_enable mmx) \
- $(use_enable sse) \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ $(use_enable cpu_flags_x86_sse sse) \
$(use_enable jpeg) \
$(use_enable png) \
$(use_enable mng) \