summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libedit/files/libedit-20061103-glibc.patch')
-rw-r--r--dev-libs/libedit/files/libedit-20061103-glibc.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/dev-libs/libedit/files/libedit-20061103-glibc.patch b/dev-libs/libedit/files/libedit-20061103-glibc.patch
new file mode 100644
index 000000000000..fdf15570428c
--- /dev/null
+++ b/dev-libs/libedit/files/libedit-20061103-glibc.patch
@@ -0,0 +1,17 @@
+--- netbsd-cvs/Makefile
++++ libedit-uNF/Makefile
+@@ -25,5 +26,5 @@
+ editline.3 tok_line.3 editline.3 tok_str.3
+
+ # For speed and debugging
+-SRCS= ${OSRCS} tokenizer.c history.c readline.c
++SRCS= ${OSRCS} tokenizer.c history.c readline.c vis.c unvis.c fgetln.c strlcat.c strlcpy.c
+ # For protection
+@@ -42,6 +44,7 @@
+ CPPFLAGS+=-I. -I${.CURDIR}
+ CPPFLAGS+=#-DDEBUG_TTY -DDEBUG_KEY -DDEBUG_READ -DDEBUG -DDEBUG_REFRESH
+ CPPFLAGS+=#-DDEBUG_PASTE -DDEBUG_EDIT
++CFLAGS+=-I. -include ../glibc-bsd-glue/bsdcompat.h -I../glibc-compat -I../glibc-bsd-glue
+
+ AHDR=vi.h emacs.h common.h
+ ASRC=${LIBEDITDIR}/vi.c ${LIBEDITDIR}/emacs.c ${LIBEDITDIR}/common.c