summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libxslt/libxslt-1.1.15-r1.ebuild')
-rw-r--r--dev-libs/libxslt/libxslt-1.1.15-r1.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/dev-libs/libxslt/libxslt-1.1.15-r1.ebuild b/dev-libs/libxslt/libxslt-1.1.15-r1.ebuild
deleted file mode 100644
index e9eca53f78e8..000000000000
--- a/dev-libs/libxslt/libxslt-1.1.15-r1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.1.15-r1.ebuild,v 1.2 2006/04/01 02:52:04 flameeyes Exp $
-
-inherit libtool gnome.org eutils python
-
-DESCRIPTION="XSLT libraries and tools"
-HOMEPAGE="http://www.xmlsoft.org/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="crypt debug python"
-
-DEPEND=">=dev-libs/libxml2-2.6.17
- crypt? ( >=dev-libs/libgcrypt-1.1.92 )
- python? ( dev-lang/python )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # we still require the 1.1.8 patch for the .m4 file, to add
- # the CXXFLAGS defines <obz@gentoo.org>
- epatch "${FILESDIR}"/libxslt.m4-${PN}-1.1.8.patch
-
- # Patch from CVS to fix segfault when processing certain xpath statements
- # (bug #106992)
- epatch "${FILESDIR}"/${P}-pattern_fix.patch
-
- # Patch Makefile to fix bug #99382 so that html gets installed in ${PF}
- sed -i -e 's:libxslt-$(VERSION):${PF}:' doc/Makefile.in
-
- epunt_cxx
- elibtoolize
-}
-
-src_compile() {
- # Always pass --with-debugger. It is required by third parties (see
- # e.g. bug #98345)
- local myconf="--with-debugger \
- $(use_with python) \
- $(use_with crypt crypto) \
- $(use_with debug) \
- $(use_with debug mem-debug)"
-
- econf ${myconf} || die "configure failed"
-
- # Patching the Makefiles to respect get_libdir
- # Fixes BUG #86756, please keep this.
- # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
- for x in $(find "${S}" -name "Makefile") ; do
- sed \
- -e "s|^\(PYTHON_SITE_PACKAGES\ =\ \/usr\/\).*\(\/python.*\)|\1$(get_libdir)\2|g" \
- -i ${x} \
- || die "sed failed"
- done
-
- emake || die "Compilation failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "Installation failed"
- dodoc AUTHORS ChangeLog FEATURES NEWS README TODO
-}